[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix Workstation XFCE-15.0.1.5.4 - sudo git - uwtwrapper uwt wrapper ERROR: /usr/bin/git.anondist-orig does not exist.

Greetings,
during my tests on a fresh Whonix Workstation, if the user types on the terminal:
sudo git
it receives the following error:
uwtwrapper uwt wrapper ERROR: /usr/bin/git.anondist-orig does not exist.

By using find command, exists only the following file:
/usr/bin/git.anondist

Is it needed to make a symbolic link of this file called /usr/bin/git.anondist-orig? Or this last file is intended for different usage?

If I make the symbolic link, after executing sudo git, I receive the following error:
uwtwrapper uwt wrapper ERROR: More than uwtwrapper_counter 10 nested executions (uwtwrapper_max: 10).

How can we fix?

Thank you

The only thing to do:

Install the git package. As per:
https://www.whonix.org/wiki/Install_Software#Install_from_Debian_stable

https://www.whonix.org/wiki/Root#Inappropriate_Use_of_Root_Rights

Hello @Patrick, I tried to change the /usr/lib/uwtwrapper file with the code shown in your link above, but when I try to re-type on terminal sudo git or also sudo apt-get install <package-name>, I get the following error:

user@host:~$ sudo apt-get install rdesktop 
[sudo] password for user:             
/usr/bin/apt-get: line 14: /usr/lib/uwtwrapper: Permission denied
/usr/bin/apt-get: line 14: exec: /usr/lib/uwtwrapper: cannot execute: Permission denied

The content of /usr/bin/apt-get is:

#!/bin/bash

## Copyright (C) 2012 - 2020 ENCRYPTED SUPPORT LP <adrelanos@riseup.net>
## See the file COPYING for copying conditions.

#### meta start
#### project Whonix
#### category networking
#### description
## uwt wrapped application
#### meta end

export uwtwrapper_parent="${BASH_SOURCE[0]}"
exec /usr/lib/uwtwrapper "$@"

The mentionet line 14 is the last one of this file above. So, I get permission denied despite I used sudo.

If you deleted /usr/lib/uwtwrapper and re-created /usr/lib/uwtwrapper…?

Ten that file will miss executable permission.

sudo chmod +x /usr/lib/uwtwrapper

There will be no such issues when upgrading the package (from source code).

1 Like

Thank you @Patrick, it works now.

1 Like

Great, thanks for following up on forum topics! :slight_smile:

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]