[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix workstation update unable to authenticate after multiple attempts, and gateway whonix update suspected cause of deletion of host PGP 64bit linux exe

Hello,

 I had a number of unexplainable issues just occur and I am not sure what to make of any of it.  First off there was a very long Gateway update again I don't know the size as it no longer says how many packages it is.  The gateway updates updated fine with no issues.  I then checked for updates on the workstation and found that there were no updates.

 The following day I ran gateway did I whonix check and everything was up to date but when I ran workstation I got a message I have never seen before.  It said that it was unable to read and obtain a whonix check and that I should run an update manually.  Which I did.  This update ran and asked me permission regarding the affected disk space I said yes and immediately it said that old files were used new ones were not available or something to that nature.  I then closed it out and reran another Whonix check and again it said that there were packages to install this time it did NOT say that it was unable to read it just said that I need to update and install packages. 

 So once again I ran the update it again asked me premissions regarding disk space I typed Y then the next branch of text in the terminal said "Warning packages can not be verified do you want to continue" to which I said no.  I then tried rebooting and trying again as this has worked in the past. 
 
 Again I ran a whonix check and it told me that I I needed to update so I opened up the terminal and began to update.  This time I got the message that old files were used due to inavailability of new ones.  This time I typed in the update command which instantly gave me a bunch of errors saying that whonix could not run, stream isolation could not run, and connection to tor was not possible.

 I kept trying to update after rebooting whonix gateway and workstation and kept getting the same issue that it was trying to get me to install something that was not authenticated.

Now here is the REALLY weird part. I don’t know if this is related but when I opened my host download folder where I have PGP4USB I had all the extracted files EXCEPT the ones that runs for Linux 64bit I am 100% sure I did not delete this, I even checked the trash to make sure. Furthermore I noticed that when I clicked on downloads the window itself was locked to be a rectangular window that could not be adjusted. So I could not see what files were in there. I had to click on one and use the arrow keys to scroll down it was then that I noticed that my PGP4USB linux64 exe file was no longer in the downloads folder. Fortunately I have all my keys on my workstation PGP but it seems I have magically lost all my PGP keys on my host. When I reinstalled a new PGP4USB with the linux64 exe file it opened like there were no keys saved. I have never had anything like this happen, and I am very new to Linux so if I was to be hacked it would be a sitting duck. Can you please advise on how to get the authenticated update?? Is it still safe to use the workstation without the update?? Do you have any idea how any of this could have caused the disappearance of my host PGP4USB exe file??

 I apologize in advance as I very new to Linux and whonix so I don't know the proper lingo, so please forgive my lack of knowlege and ability to effectively explain my problem I hope what I said made sense.

Thanks

Good day,

sorry, but using PGP4USB with Whonix isn’t recommended. Use KGPG, it’ bundled with Whonix.

Have a nice day,

Ego

Updating is documented here:

https://www.whonix.org/wiki/Update

No I don’t use PGP4USB with whonix I use it on the host on whonix I use KGPG my point is somehow the PGP4USB 64 bit linux exe file (the ONLY one I use) from the many exe files that are there from the zip extraction was some how deleted. That is what I don’t understand what would cause the one exe file that I use on my host to be deleted I don’t know that it has anything to do with whonix update but I do know that it happened after I completed the gateway update.

It is very much unlikely that PGP 64bit linux exe on the host would
influence anything inside Whonix.

Ok I have tried everything the update link suggested and I am still getting the following message:

The following packages will be upgraded:
apt apt-transport-https apt-utils base-files ca-certificates file
libapt-inst1.5 libapt-pkg4.12 libc-bin libc-dev-bin libc6 libc6-dev
libgudev-1.0-0 libjavascriptcoregtk-3.0-0 libldap-2.4-2 libmagic1
libpam-modules libpam-modules-bin libpam-runtime libpam-systemd libpam0g
libpcre3 libperl5.20 libraw10 libssh-gcrypt-4 libsystemd0 libudev1 libvlc5
libvlccore8 libwebkitgtk-3.0-0 libwebkitgtk-3.0-common linux-kbuild-3.16
locales login multiarch-support openvpn passwd perl perl-base perl-modules
rsyslog systemd systemd-sysv tzdata udev vlc vlc-data vlc-nox
vlc-plugin-pulse
49 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 51.1 MB of archives.
After this operation, 958 kB disk space will be freed.
Do you want to continue? [Y/n] y
WARNING: The following packages cannot be authenticated!
base-files login perl libperl5.20 perl-base perl-modules libc6-dev
libc-dev-bin libc-bin libc6 libapt-pkg4.12 apt libudev1 udev libsystemd0
systemd systemd-sysv libpam-systemd libpam0g libpam-modules-bin
libpam-modules libpam-runtime libpcre3 libapt-inst1.5 libldap-2.4-2 file
libmagic1 libgudev-1.0-0 libwebkitgtk-3.0-common libwebkitgtk-3.0-0
libjavascriptcoregtk-3.0-0 libraw10 libssh-gcrypt-4 multiarch-support passwd
tzdata apt-utils rsyslog locales apt-transport-https ca-certificates vlc
vlc-plugin-pulse libvlccore8 vlc-data vlc-nox libvlc5 linux-kbuild-3.16
openvpn

I cannot seem to get it to authenticate I have tried new tor circuits I have tried running the commands suggested and attempting to upgrade again still I can not get the upgrade to authenticate. The upgrade link suggests that if I keep getting this something must be broken what could be causing this?? Any advice??

Thanks

Also when I run a whonix check I get the following message which I don’t normally get:

INFO: Whonix News Result:
√ Up to date: whonix-workstation-packages-dependencies 2.9-1
√ Up to date: Whonix Build Version: 11.0.0.3.0
WARNING: Debian Package Update Check Result: Could not check for software updates! (apt-get code: 125)
Please manually check:
(Open a terminal, Start Menu -> Applications -> System -> Terminal.)
sudo apt-get update && sudo apt-get dist-upgrade

I have never had it be unable to check for new updates.

Just re-run sudo apt-get update as suggested in documentation.

Thank you Patrick but believe me I have tried that many times I am definitely new but I wouldn’t bother posting if the solution posted actually worked for me. When I run commandthat I get the following:

W: GPG error: http://ftp.us.debian.org jessie Release: The following signatures were invalid: BADSIG 8B48AD6246925553 Debian Archive Automatic Signing Key (7.0/wheezy) ftpmaster@debian.org

Then when I run get update again I get the same thing. It says something about possible man in the middle attacks when it comes to signatures being bad could that be what is happening?

You’re using an outdated version of Whonix which is Debian wheezy based.
In that case, upgrade if that still works or get newer Whonix.

Or you accidentally added a wheezy line to your sources list. In that
case, remove those.

Ok again forgive my the fact I am a Linux noob. I am running Ubuntu 14.04, I was under the noob’s impression that when I update the Whonix packets that I was updating to a newer version of Whonix itself. Do I have to actually download fresh imagines and import them back to VB and then reinstall my chat clients and PGP contacts info?? Do you think that is the problem?? I am totally unfamiliar with Wheezy I don’t know how I would have got it. As the only thing I ever download or change is when there are new whonix packages to install.

Thanks in advance!!

So only command I ever type in is the update command to run the new whonix packages. I don’t know where Wheezy lines would have been added. What do you suggest I do?? Does this happen when you have been running whonix for awhile?? Where it goes outdated and you have to get new images?

whonixcheck Whonix News should inform you when your Whonix version is
outdated.

Wheezy based Whonix is old.

Follow latest important news according to:

Otherwise after so much time passed it creates a mess for everyone.

The upgrading instructions may or may not work. (Since they’re old and
we’re at Whonix 12 already.)

If they don’t work, it’s unsupported. (
https://www.whonix.org/wiki/FAQ#What_do_you_mean_by_unsupported.3F )

So the easiest would be importing new images.

It sounds like because I am running an untested host Ubuntu and VB that the whonix check did not update from 11 to 12. So like the link above says unsupported tasks pile up and one has to eventually manually upgrade. You are correct those instructions do not work. Should I just go to the Whonix website and just download the latest image and install on VB? Is that the best solution since the above does not work??

The host is unrelated here.

whonixcheck doesn’t update. It informs about missing Debian, and Whonix updates.

More complex upgrades such as when Debian requires a suite (wheezy -> jessie) upgrade always required special steps. That’s the case in Debian so Whonix since based on Debian can’t magically make this go away. You’ll find out about that in whonixcheck and by following the news. Once instructions are posted these are working for most people and supported for one month.

As already said, downloading and importing new images would be easiest.

Thank you for you help and patience.

I found a reasonably priced PC that is compatible with Qubes so I hope to try running Whonix on Qubes although I assume it is much more advanced than running it on VB,

LOL just downloaded Whonix 12 and ran it for the first time and same problem gateway works but workstation whonix check gives me this:

NFO: Whonix News Result:
√ Up to date: whonix-workstation-packages-dependencies 2.9-1
√ Up to date: Whonix Build Version: 12.0.0.3.2
WARNING: Debian Package Update Check Result: Could not check for software updates! (apt-get code: 100)
Please manually check:
(Open a terminal, Start Menu -> Applications -> System -> Terminal.)
sudo apt-get update && sudo apt-get dist-upgrade

I ran a manual get update and then ran whonix check again to see if I was up to date and got the same message.

Tried again from a new tor connection and got same message.

Again thanks for your help and patience.

Also noticed when running the gateway although it runs fine it says “Failed to create encrypted swap file” What does that mean?? With all these problems do you think I should just use TBB until I have a laptop I can run Qubes on?

Patrick again thank you for all of your help and time. At this point aside from what is mentioned above when I run sudo apt-get update I get the following order of messages on terminal. Please advise what could be the problem. Again I have tried new tor connections several times. Thanks again

user@host:~$ sudo apt-get update
[sudo] password for user:
Ign http://ftp.us.debian.org jessie InRelease
Get:1 http://mirror.whonix.de jessie InRelease [13.1 kB]
Hit http://security.debian.org jessie/updates InRelease
Ign http://deb.torproject.org jessie InRelease
Get:2 http://mirror.whonix.de jessie/main i386 Packages [41.6 kB]
Err http://ftp.us.debian.org jessie Release.gpg
Connection failed
Hit http://security.debian.org jessie/updates/non-free i386 Packages
Ign http://ftp.us.debian.org jessie Release
Err http://deb.torproject.org jessie Release.gpg
Connection failed
Ign http://ftp.us.debian.org jessie/main i386 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/non-free Translation-en
Ign http://ftp.us.debian.org jessie/contrib i386 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/main i386 Packages
Ign http://ftp.us.debian.org jessie/non-free i386 Packages/DiffIndex
Hit http://security.debian.org jessie/updates/contrib i386 Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Ign http://deb.torproject.org jessie Release
Hit http://security.debian.org jessie/updates/main Translation-en
Ign http://mirror.whonix.de jessie/main Translation-en_US
Ign http://mirror.whonix.de jessie/main Translation-en
Ign http://deb.torproject.org jessie/main i386 Packages/DiffIndex
Hit http://ftp.us.debian.org jessie/contrib Translation-en
Hit http://ftp.us.debian.org jessie/main Translation-en
Hit http://ftp.us.debian.org jessie/non-free Translation-en
Hit http://ftp.us.debian.org jessie/main i386 Packages
Hit http://ftp.us.debian.org jessie/contrib i386 Packages
Ign http://deb.torproject.org jessie/main Translation-en_US
Hit http://ftp.us.debian.org jessie/non-free i386 Packages
Ign http://deb.torproject.org jessie/main Translation-en
Hit http://deb.torproject.org jessie/main i386 Packages
Ign http://ftp.us.debian.org jessie/contrib Translation-en_US
Ign http://ftp.us.debian.org jessie/main Translation-en_US
Ign http://ftp.us.debian.org jessie/non-free Translation-en_US
Fetched 13.1 kB in 26s (502 B/s)
W: Failed to fetch http://ftp.us.debian.org/debian/dists/jessie/Release.gpg Connection failed

W: Failed to fetch http://deb.torproject.org/torproject.org/dists/jessie/Release.gpg Connection failed

E: Some index files failed to download. They have been ignored, or old ones used instead.
user@host:~$

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]