Whonix Wiki Download Docs News Support Tips Issues Contribute DONATE

Whonix-Workstation update problem - ERROR: Debian Package Update Check Result: Upgrade simulation failed!

Hello to all,

When I use Whonix, I always start by doing a system check with the Systemcheck tool. This allows me to know if an update is necessary.
I have never had a problem updating the Whonix-Gateway, but I am currently having a problem updating the Whonix-Workstation.
Here is the error message displayed by Systemcheck:

ERROR: Debian Package Update Check Result: Upgrade simulation failed!

To fix, try running these commands:
(Open a terminal, Start Menu → System → Terminal.)
sudo dpkg --audit
sudo dpkg --configure -a
sudo apt-get dist-upgrade

Debugging information:
sudo apt-get dist-upgrade --simulate exit code: 100
sudo apt-get dist-upgrade --simulate output:
Reading package lists…
Building dependency tree…
Reading state information…
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
linux-headers-5.10.0-19-amd64 : Depends: linux-headers-5.10.0-19-common (= 5.10.149-2) but 5.10.149-1 is installed
Depends: linux-kbuild-5.10 (>= 5.10.149-2) but 5.10.149-1 is installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).
If you know what you are doing, feel free to disable this check. Create a file /etc/systemcheck.d/50_user.conf and add:
systemcheck_skip_functions+=" check_operating_system "

(I get the same error message when I try to update the Workstation using the following command: sudo apt-get-update-plus dist-upgrade)

So could someone help me to fix this update problem?

Thanks in advance for your help!

Please try as instructed by systemcheck’s output.

Hello Patrick,

I tried the commands indicated by Systemcheck and here is the terminal result:

user@host:~$ sudo dpkg --audit
[sudo] password for user :         
The following packages are in disarray due to serious problems during the installation.
installation.  They must be reinstalled to work properly (as well as all packages that depend on them).
They (and all packages that depend on them) work correctly:
 linux-headers-5.10.0-19-common header files for Linux 5.10.0-19

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 linux-headers-5.10.0-19-amd64 Header files for Linux 5.10.0-19-amd64
 linux-headers-amd64 Header files for Linux amd64 configuration (meta-package)

user@host:~$ sudo dpkg --configure -a 
dpkg: dependency problems prevent configuration of linux-headers-5.10.0-19-amd64 :
 linux-headers-5.10.0-19-amd64 depends on linux-headers-5.10.0-19-common (= 5.10.149-2); however:
  The package linux-headers-5.10.0-19-common is not installed.
 linux-headers-5.10.0-19-amd64 depends on linux-kbuild-5.10 (>= 5.10.149-2); however:
  The version of linux-kbuild-5.10 on the system is 5.10.149-1.

dpkg: linux-headers-5.10.0-19-amd64 package processing error (--configure):
 dependency problems - leaves unconfigured
dpkg: dependency problems prevent linux-headers-amd64 from being configured:
 linux-headers-amd64 depends on linux-headers-5.10.0-19-amd64 (= 5.10.149-2); however:
  The package linux-headers-5.10.0-19-amd64 is not yet configured.

dpkg: error processing the linux-headers-amd64 package (--configure):
 dependency problems - leash not configured
Errors were encountered while processing :
user@host:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building the dependency tree... Done
Reading status information... Done
You can run 'apt --fix-broken install' to fix these problems.
The following packages have unmet dependencies:
 linux-headers-5.10.0-19-amd64: Depends on: linux-headers-5.10.0-19-common (= 5.10.149-2) but 5.10.149-1 is installed.
                                 Depends on: linux-kbuild-5.10 (>= 5.10.149-2) but 5.10.149-1 is installed
E: Dependencies not met. Try 'apt --fix-broken install' without packages (or specify a solution).

Do you think I should reinstall Whonix (using VirtualBox)

Thanks for your help!

sudo apt --fix-broken install

Not necessarily.


(Whonix is based on Kicksecure.)