[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix Workstation on VB doesn't display desktop, only the panel. Apps still work but without the bar above to close them

Hi, I’m a new user to Whonix so I do apologise if there’s a really obvious problem/solution I missed, but the gist is that after a restart, Whonix started to not display: the desktop (it’s all black without icons), the cursor when it’s in said desktop, and the bar above applications that allow closing/minimising (idk what those called). Also, when I turn off full screen in VB and turn it back on again, it shows the desktop (background and app icons) but now the panel is gone and the cursor is also gone.

All I did in that session was install a few things, which I don’t think should have completely murdered my desktop…

I don’t think it’s not a RAM problem since I have plenty of that. VirtualBox is the recommended version (6.1). So I’m really scratching my head…

I’m really sorry about not being able to provide more detail on the whole “after restart = dead” thing, and thank you all in advance!

Try to run on the server black screen ctrl+alt+F2 (or f3 f4 …f8)

I’m sorry but I don’t understand what you mean by that. Pressing those buttons don’t do anything. I’m already on ctrl+alt+F2.

Virtual Consoles

Hi, thank you for responding, but I don’t think my problem was described in the resource you linked. It’s not a full black screen or anything, and I’m not stuck on the CLI. I’m on the graphical interface but it’s just not displaying my desktop. Like I said above, I can click on apps in the panel (taskbar) normally and get them to run.

I’ve tried a few workarounds listed in the resource but they don’t seem to work.

As for the virtual console thing, I’m still confused as to what I’m supposed to do there… I would prefer not having to use all the time.

Screen resolution issue? The VirtualBox host window too small to show the full desktop?

Screenshot would be helpful.

Try this:

I don’t think it’s a screen resolution issue since I haven’t touched the VirtualBox’s resolution option at all since installing Whonix and it worked just fine out of the box.

Here’s the screenshot (a small portion at least but enough to convey the gist? Also I can’t post links 'cause this account is new so just close it up): anonfiles.com/71B5p50bv9/Untitled_png

The panel is above and the black abyss below is my desktop. It’s like that throughout the rest of the desktop, no icons, nothing. At this point, I’m starting to think a gnome broke into my house and cursed my Whonix.

I’ll try running Debian on the VB to see if it’s all wacky. Cheers!

File not downloadable / viewable.

Huh, that’s strange, I can view the file just fine even now.

What’s the issue? A black desktop background? Not an issue. Change the wallpaper if you must.

Default Home Folder Configuration Files Reset

Oh how I wish it was just a background lol! If it were I wouldn’t have bothered you guys with it. Unfortunately, it’s not and I can’t just change the wallpaper and be done with it. The problem isn’t that the desktop background is black; it’s that the desktop itself is black. I can’t interact with anything on the desktop (I had shortcuts there before) nor I can see any of the said shortcuts. It’s as if there’s a solid black box in front of my desktop.

I’ve also tried the resource you linked and sadly that didn’t help. And yes, I’m sure I did it properly (I think the wiki has a mistake btw, step two says systemct which is supposed to be systemctl?)

I might just import a fresh whonix and chalk this whole curse up to space radiation hitting my pc and irreparably breaking whonix in the process, or maybe it was that gnome.

I am still not sure what this bug is about. The screenshot doesn’t look so bad. The usual start menu and a black desktop background image. Doesn’t show anything wrong.

What would normally happen? Did you previously use Whonix without such issues?

What is expected to happen?

What is actually happening?

For that we wrote:

https://www.whonix.org/wiki/Reporting_Bugs#Reporting_Guidelines

Right, I guess I should have taken a better screenshot, sorry about that. How about this? This screenshot shows the fact that there are no icons on the desktop while there’s supposed to be and the fact that there’s only one workspace (look at the right side). And again, I didn’t set the background colour to black.

Here’s a re-formatting of my beginning post, hopefully making things a bit clearer?

Expectation and what happens on a fresh import:

  • Whonix Workstation is booted up normally (not live mode or advanced)
  • A desktop with icons and the set background colour/image should be displayed on screen together with the panel, which should have several work spaces on them in the right hand side
  • Applications, when opened, should show a top bar where one can close/minismise/hide window

Problem:

  • Whonix Workstation is booted up normally
  • An entirely black desktop with no icons is shown, despite the fact that there are supposed to be icons there and the black is not the set background colour
  • No cursor is shown when moved into desktop space
  • Applications, when opened, don’t show a top bar where one can close/minismise/hide window/move

Bloody hell, I think I found it. It’s the damned “save session for future logins” option when shutting down/restarting.

Here’s how to re-produce this bug (at least for me):

  • Import a fresh Whonix
  • Do all the updates (upgrade-nonroot)
  • Download Element-desktop (with the commands from their website)
  • Log into an account (not sure if this step is necessary, haven’t checked)
  • Restart with the “Save session for future logins” option checked
  • Upon next login, the desktop will be dead/black, no cursor, only one workspace

Another note, purging element-desktop with sudo apt-get --purge remove element-desktop (and for good measure, sudo apt-get autoremove) doesn’t work to reverse the bug. Resetting settings on that VM doesn’t work either (following this resource).

1 Like

I deleted my saved session in the Session and Startup manager, and it’s back to normal. That simple…

Welp, sorry for this whole thing, and thank you for spending the time and effort to respond. I probably would have given up on the OS otherwise.

Great finding. Glad you figured that out.

Yeah, that’s the problem. I am not save session for future logins. I don’t even know a why how to not have that installed. And not using it because it might cause issues for which I didn’t have evidence before.

It’s available, because… See Linux User Experience versus Commercial Operating Systems

I find it very conceivable that this is only a bug related to login session saving and unrelated to element-desktop? That would be an Xfce bug.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]