[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Workstation failing to install

Hello. I downloaded Whonix-Gateway and Whonix-Workstation, and verified both to be okay with the openPGP signature/key. I have followed the instructions for installing on a Vbox on my Win 8 PC as the host. The Whonix-Gateway succesfully installed. However the Whonix-Workstation is failing to install and I get the following error:

Failed to import appliance C:\Users\kay1\Desktop\Useful Utilities\Whonix-Workstation-9.3.ova.

Machine settings file ‘C:\Users\kay1\VirtualBox VMs\Whonix-Workstation\Whonix-Workstation.vbox’ already exists.

Result Code: VBOX_E_FILE_ERROR (0x80BB0004)
Component: Machine
Interface: IMachine {480cf695-2d8d-4256-9c7c-cce4184fa048}

Failed to import appliance C:\Users\kay1\Desktop\Useful Utilities\Whonix-Workstation-9.3.ova.

<vbox:Machine> element in OVF contains a medium attachment for the disk image 3633fa10-b8c5-48f7-a98a-620d692fbc8a but the OVF describes no such image.

Result Code: E_FAIL (0x80004005)
Component: Appliance
Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}

Would be very grateful if somebody could assist in resolving this issue please. Thanks

If it’s verified, it looks more like a VirtualBox than Whonix error. (Otherwise we would have seen reports of this earlier.) Sometimes due to power loss, hdd corruption [or VirtualBox bugs?] VirtualBox’s settings file is broken and very difficult to repair.

Got no other VMs that you care to backup? Otherwise back them.

Perhaps try this…

Uninstall VirtualBox.

Delete VirtualBox settings folder.
“C:\Users\kay1\Desktop/.VirtualBox”
(?)

Delete VirtaulBox VMs folder.
“C:\Users\kay1\VirtualBox VMs”

Reinstall VirtualBox.

Does it work now?

Hi Patrick. thanks for your response. I am a bit reluctant to uninstall the VM box because I have other VMs with other OS on it, which took me a while to install, update etc. What I don’t understand is that Whonix-Gateway installed Ok. However, Whonix-Workstation gets to 99% installation and then it stops and come up with the error. Why is it reporting that Workstation.vbox’ already exists (in the error message)? Thanks

I don’t know. I am quite certain it’s not caused by anything Whonix does.

Probably caused by a broken .VirtualBox folder. And diagnosing/fixing that is super difficult. So I have no better idea than above.

Besides… If you’re not sure it’s not caused by Whonix… Use another Windows user account you have not with VirtualBox and try to import Whonix VMs there. If it works, it’s an indicator that it’s likely a broken .VirtualBox settings folder.

Okay, thanks for your assistance.

Okay, I have managed to resolve this myself. Like I stated before, I was a bit baffled by this statemnet in the error message: "Machine settings file ‘C:\Users\kay1\VirtualBox VMs\Whonix-Workstation\Whonix-Workstation.vbox’ already exists."
So what I did, I navigated to where this folder is meant to be and deleted it, and then tried to import/install again, and it worked!

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]