[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Workstation does not work

my workstation no longer connects to Tor, I can’t figure out what happened …

Share a little more info about what you were doing when you could no longer connect, otherwise i cant magically help know what you were doing/what the error is. I’m sure some knowledge folk will come around and give you some troubleshooting tips.

The gateway has not been modified, if I try to verify whonixcheck I receive a message of successful connection, the problem is in the workstation part that cannot connect to the gateway.

for example I realized that the time and date on the workstation cannot synchronize:

how can I restore “sdwdate” correctly?

Did you pause or suspend your Whonix VMs proir to this happening?

Try running whonixcheck in WhonixWorkstation and Whonix-Gateway.

1 Like

I have already done whonix check on the gateway and it works perfectly, the problem is on the workstation where even the recovery of swdate fails

This looks like KDE. What happens if you try to run a more recent Whonix workstation release? Do you have more than one workstation running in parallel?

By the way, a screenshot of the Whonix Workstation itself would suffice, you are revealing too much information about yourself with the Windows taskbar there.

Yes, I tried using whonix workstation and kali linux with the same whonix gateway.

I can’t make neither whonix workstation nor kali work.

I ran whonixcheck on the gateway and it works great.

I think the problem is in the date, swdate indeed on whonix workstation receives an error.

I found this document where it explains how to make the whonix gateway multiple, unfortunately my whonix workstation will now have the same name as “internal network” and the network card is confused, how can I restore it so that it reconnects to the gateway?
https://www.whonix.org/wiki/Multiple_Whonix-Gateway

Undo any step that you previously applied.

the strange thing is this, I have not applied any changes neither to the whonix gateway nor to the whonix workstation?

only the gateway works but kali and whonix workst. they no longer connect to TOR

Steps required when adding a new Workstation:

Generate new random MAC at VirtualBox (Settings-Network-Advanced)

Change the VM’s IP:
sudo nano /etc/network/interfaces.d/30_non-qubes-whonix

Increase last number in “address 10.152.152.11”

then restart:
sudo service networking restart

Edit: this is when adding another whonix workstation (your problem is likely conflict of two VMs having the same IP). How to configure Kali as a workstation will probably take more steps.

To make sure this is your issue, shut down the Kali machine and try to connect with the Whonix Workstation (provided you did not make any changes there).

I changed the Mac address from VM’s whonix workstation, started the VM and ran:

  1. sudo nano /etc/network/interfaces.d/30_non-qubes-whonix

  2. sudo service networking restart

Does the Whonix Workstation connect when the Kali machine is powered off?

I abandoned kali for now, I’m trying to restore whonix workstation but I can’t get it to connect to TOR

KALI is OFF.

Any changes done to the workstation or to VirtualBox?

IT IS INCREDIBLE, I HAVE NOT DONE ANY MODIFICATION TO WHONIX Neither GATEWAY OR WORKSTATION

ok i succeeded to work the workstation

missed the flag in the “connected network” on the virtualbox setting.

thanks to all the same.