[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix VirtualBox VMs no longer boot after updating

Need a bit of help guys, i was far from the PC for several weeks and i decided to start a new set of whonix boxes next to my existing ones(the one i’m typing from) when i got to the update it gave me these choises:
Configuration file ‘/etc/machine-id’
==> File on system created by you or by a script.
==> File also in package provided by package maintainer.
What would you like to do about it ? Your options are:
Y or I : install the package maintainer’s version
N or O : keep your currently-installed version
D : show the differences between the versions
Z : start a shell to examine the situation
The default action is to keep your current version.
*** machine-id (Y/I/N/O/D/Z) [default=N] ?

I went for N and when i restarted the machine it got stuck on Started Update UTMP about System Runlevel Changes

And never got beyond that, now I’m on my old whonix VB and i updated and it gave me the same choise.

I’ts never done something like this before, is it because i started a second set of virtual boxes?

Install.

Related: Anonymize /etc/machine-id

Unrelated to above one most likely.

But I don’t know the solution.

Probably not.

Hello, update is broken. I got exactly same issue. After downloading last version of Whonix for VirtualBox, I started Gateway and during process of update I am getting same message as above. I am choosing install I (or Y or anything else) and after restart I am getting this. It is related to it for 100%, see my screen captures. Thank you for fix in advance. https://ibb.co/6gcV23B & https://ibb.co/GMMcx4G .

Sorry about this.


To manually fix, login into a virtual console.

The VirtualBox default is Right Ctrl + F1 .

Then run the following commands. Delete the offending config file:

sudo rm /etc/default/grub.d/40_only_allow_signed_modules.cfg

Update grub.

sudo update-grub

Reboot.

sudo reboot

Should be fixed after reboot.


Fix through apt-get upgrades coming soon.


(For technical background, see: allow loading signed kernel modules by default / disallow kernel module loading by default)

To fix through apt-get upgrades.

Login into a virtual console.

The VirtualBox default is Right Ctrl + F1.

Then upgrade.

sudo apt update
sudo apt dist-upgrade

Reboot.

sudo reboot

Should be fixed after reboot.

Hello, thank you very much for fix. I just tried new clean installation and I choose approach to fix trough apt-get updates, but now I have different issue, I cen get trough update. TIMESYNC ERROR 9 times and then nothing. See screen capture: https://ibb.co/C16QCZt .

This can be safely ignored.
What’s happening is that virtualbox-guest-utils is asking VirtualBox for the time. Which is blocked as per Whonix default VirtualBox VM settings.
Previously this was disabled inside the VM too through pacakge https://github.com/Whonix/vbox-disable-timesync but this was recently disabled since it causes more issues than it does good. This error message we have to live with but it doesn’t break anything.

No idea yet.

Could be that rads hangs when run in a virtual console.

Try another virtual console. Right Ctrl + F2. Try to see what hangs.

sudo ps aux | more

Yes. Try from virtual console 2.

rads is a bit weird but it works.

Then just reboot.

Should be fine after upgrade and reboot.

Hello again, I think I figure it out. I started update trough Terminal Emulator. Trough Terminal Emulator I was asked about “Anonymize machine-id” so i chose I to install. In Virtual Console I was not asked, weird. And now after correct update procedure I reboot and everything seems fine. Thank you again for your help and expertise.

Will be improve in next version.

A post was merged into an existing topic: “Setting up anon-base-files” shows machine-id prompt "Configuration file ‘/etc/machine-id’ “install the package maintainer’s version”?

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]