[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix VirtualBox / KVM 14.0.0.5.7 Testers Wanted!

Entirely untested for now.

Testers wanted!

https://download.whonix.org/linux/14.0.0.5.7/

3 Likes

I discovered a silly xml mistake in the GW settings which I shall promptly correct.

@iry please justify the Whonix logo by a line or 2 to the left so its centered in Tor Browser’s default, reduced size window.

I think we should trigger Whonix setup automatically to avoid confusing new users who will wonder why Whonix isn’t connecting. Though in my situation I don’t know if its not connecting because I haven’t agreed to the discalimer or something else.

Please change the eye sore that is the default wallpaper to something less inducing to seizures :slight_smile: I think giving the GW a different vs the WS makes sense so a user doesn’t accidentally install packages on the wrong one.

Tor isn’t connecting for some reason. I restarted it from the script “restart Tor”. I tried using arm to diagnose any errors but it says Tor controlport connection refused. Same with the whonixcheck output in the WS. on GW the Whonix setup wizard closes after pressing connect without giving feedback.

1 Like

Hi HulaHoop!

HulaHoop:

@iry please justify the Whonix logo by a line or 2 to the left so its centered in Tor Browser’s default, reduced size window.

No problem! I will be working on it tomorrow!

I think we should trigger Whonix setup automatically to avoid confusing new users who will wonder why Whonix isn’t connecting.

I agree with you. Do you have any concern not to trigger it
automatically, @Patrick ?

Though in my situation I don’t know if its not connecting because I haven’t agreed to the discalimer or something else.

The disclaimer has been reomoved since Whonix 14. :slight_smile:

Please change the eye sore that is the default wallpaper to something less inducing to seizures :slight_smile: I think giving the GW a different vs the WS makes sense so a user doesn’t accidentally install packages on the wrong one.

Good suggestion! I am not sure how to do this though. Do you have any
idea, @Patrick ?

Tor isn’t connecting for some reason. I restarted it from the script “restart Tor”. I tried using arm to diagnose any errors but it says Tor controlport connection refused. Same with the whonixcheck output in the WS. on GW the Whonix setup wizard closes after pressing connect without giving feedback.

When doing ls -l /var/run/tor, do you see a file called control?

If not, this is very likely because we have used systemd to (re)start
Tor with a DisableNetwork 1 value.

It can be solved by adding DisableNetwork 0 to one of the torrc files
(recommended place for the line: /usr/local/etc/torrc.d/50_user.torrc)
and then starting Tor again using systemd.

The report for that strange behavior can be found here:
https://lists.torproject.org/pipermail/tor-dev/2018-January/012824.html

Thank you so much for your valuable feedback!

1 Like

iry:

HulaHoop:

@iry please justify the Whonix logo by a line or 2 to the left so its centered in Tor Browser’s default, reduced size window.

No problem! I will be working on it tomorrow!

I think we should trigger Whonix setup automatically to avoid confusing new users who will wonder why Whonix isn’t connecting.

I agree with you. Do you have any concern not to trigger it
automatically, @Patrick ?

If Tor is not enabled, should be auto started on Whonix-Setup-Wizard
should be auto started which then starts acw. If it doesn’t, it’s a bug.
Please fix.

Though in my situation I don’t know if its not connecting because I haven’t agreed to the discalimer or something else.

The disclaimer has been reomoved since Whonix 14. :slight_smile:

Yes.

Please change the eye sore that is the default wallpaper to something less inducing to seizures :slight_smile: I think giving the GW a different vs the WS makes sense so a user doesn’t accidentally install packages on the wrong one.

Good suggestion! I am not sure how to do this though. Do you have any
idea, @Patrick ?

No one could figure how to change wallpapers in the KDE version shipped
in Debian stretch.

Thanks @iry. I unfortunately removed everything before I posted however I recall there was state and control files under /var/run/tor.

All in all Whonix 14 is shaping to be a great release. It took its sweet time but by God I can’t wait.

2 Likes

6 posts were split to a new topic: Use different Wallpaper for Whonix-Gateway to distinguish from Whonix-Workstation

Sorry for the delay. Done:

https://github.com/Whonix/whonix-welcome-page/pull/3

Again, thank you so much for your feedback, @HulaHoop !

2 Likes

@Patrick Whonix GW 14 has static addressing right? It should be able to connect if the NAT subnet is 10.0.2.0/24.

HulaHoop:

@Patrick Whonix GW 14 has static addressing right?

Yes.

1 Like

This excludes that as a reason for dis-connectivity. Has anyone reproduced the Tor connection problems?

I like the new interface - there are a few oddities - there is a folder called desktop which shows the usual desktop shortcuts these shortcuts are not on the actual desktop??

It’s easy to change the desktop background to another image, maybe remove the image from the gateway

I have tried to use the ricochet chat but it fails to get a port to connect, also the initial setup I had to run from the console as the icon did nothing?

any chance of getting cryptochat included?

keep up the good work

1 Like

TechieMike:

I like the new interface - there are a few oddities - there is a folder called desktop which shows the usual desktop shortcuts these shortcuts are not on the actual desktop??

Would be good indeed.

We don’t know how to enable desktop shortcuts by default after extensive
research, i.e. kde folderview in stretch’s KDE version.

Probably has to wait for stretch + 1, i.e. Debian buster where
folderview is enabled by default.

It’s easy to change the desktop background to another image, maybe remove the image from the gateway

Has a separate thread in this forums.

I have tried to use the ricochet chat but it fails to get a port to connect, also the initial setup I had to run from the console as the icon did nothing?

https://www.whonix.org/wiki/Next#ricochet

any chance of getting cryptochat included?

Unlikely atm. First it would have to be uploaded to packages.debian.org.

keep up the good work

Thanks! :slight_smile:

1 Like

Thanks for the info I tired the ricochet info and get the following error

user@host:~$ sudo mkdir -p /usr/local/etc/onion-grater-merger.d/
[sudo] password for user:
user@host:~$ sudo cp /usr/share/onion-grater-merger/examples/40_ricochet.yml /usr/local/etc/onion-grater-merger.d/
user@host:~$ sudo service onoin-grater restart

Failed to restart onoin-grater.service: Unit onoin-grater.service not found.

Also it seems you have removed the ability to change the icon size on the desktop? I was able to simply drag the shortcuts from the desktop folder to the desktop to have the same shortcuts as previous version :slight_smile:

TechieMike:

Thanks for the info I tired the ricochet info and get the following error

user@host:~$ sudo mkdir -p /usr/local/etc/onion-grater-merger.d/
[sudo] password for user:
user@host:~$ sudo cp /usr/share/onion-grater-merger/examples/40_ricochet.yml /usr/local/etc/onion-grater-merger.d/
user@host:~$ sudo service onoin-grater restart

Failed to restart onoin-grater.service: Unit onoin-grater.service not found.

You mistyped onion-grater. Also please make sure to run the onion-grater
instructions on the gateway. Let me know if the instructions don’t
mention this.

Thanks for the info I was running these command on the Gateway, the typo is in the instructions I copied and pasted I will test again and let you know.

Gateway system
I have just run a fresh install
changed user/root password
changed repository to testers
sudo whonixsetup
ran whonix check
sudo apt-get update && apt-get dist-upgrade after it finishes I get this error

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

I tried rebooting and running the command again same error

Edit I switched to stable ran sudo apt-get update && apt-get dist-upgrade - rebooted
switched back to testers ran sudo apt-get update && apt-get dist-upgrade no errors

on the Workstation fresh install same error, the only way I could install updates was to switch to root sudo -s

the onion reload command worked - the instructions need updating

thanks

Can someone guide me on installing the tor-launcher I have followed the steps for ricochet but it will not connect

thanks

TechieMike:

Thanks for the info I was running these command on the Gateway, the typo is in the instructions I copied and pasted I will test again and let you know.

Fixed! :slight_smile:

TechieMike:

sudo apt-get update && apt-get dist-upgrade
You forgot the second sudo.

sudo apt-get update && sudo apt-get dist-upgrade

TechieMike:

Can someone guide me on installing the tor-launcher

It’s unsupported.

There is

update-torbrowser

which provided by the tb-updater package.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]