[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix virtual box Tor Bootstrap error


#1

Hi, I am fairly new to Whonix so bare with me.

Everytime I load workstation & gateway on virtualbox, after a while I get a Bootstrap Tor error & have to reboot to get to work again, whonix check doesnt correct.

Im not running wifi & have no issue with host LAN connection.

Cheers.

ERROR: Tor Bootstrap Result:
Tor’s Control Port could not be reached!

Troubleshooting:

  • Confirm that Whonix-Gateway is running.
  • Run whonixcheck on Whonix-Gateway and confirm success.
  • If you’re running multiple Whonix-Workstations simultaneously, confirm that separate IP addresses are configured (see https://www.whonix.org/wiki/Multiple_Whonix-Workstations).
  • Rerun whonixcheck here in this Whonix-Workstation.

(Technical information:)
(Code: 124)
(tor_bootstrap_timeout_type: sigterm)
(tor_bootstrap_status: Variable check_bootstrap_helper_script_output is empty.)
(check_socks_port_open_test: 22)
(Tor Circuit: not established)


#2

HI Fyah_Burn

I have a few questions:

  1. Is this a new installation and you are trying to connect to Tor for the first time or have you been using Whonix ( problem free) and now you are having this problem?

  2. When you say “have to reboot to get it to work again” do you mean you are able to connect to Tor after reboot.

  3. Is Tor use censored ( blocked ) in your area.


#3

Hi 0brand, The virtual box & Whonix is a new install. I used to use Tor normally on windows no problems so definitely not blocked.
When I reboot the Work station & Gateway Tor works for a while yes, then I start to get the bootstrap errors again.
Its very frustrating…


#4

HI Fyah_Burn

Did you verify both Gateway and Workstation images?


Just for clarity have you downloaded Tor Browser Bundle on your current host operating system? If so did you have the same connection issues?

If you have not tried connecting with TBB from your current host it would be useful for troubleshooting. You don’t have to connect to any sites just see if you can maintain connection to Tor for a period of time. If its not something your feel comfortable doing its OK.


#5

I tried verifying, managed to work the command, but pgp doesnt seem to work for me. Was trying for hours too. :frowning:

Browser works fine in host.


#6

What is “a while”? 5 mins or 2 days? Is it consistent?
Have you changed any default settings? ie networking?
Are you running multiple workstations?
Does your computer keep time properly? Run date and make sure it’s proper UTC time
When you restart, are you reverting to same snapshots?
Are there any issues with the Gateway?

When everything is working, run whonixcheck on both Gateway & Workstation. Any errors?
After Control Port fails, run whonixcheck again on both machines.


#7

Hi Entropy, I only got one message today & had Whonix on all day.

I havent changed network settings.

No multiple stations.

Yes time is correct.

clean boot.

gateway seems to be okay.

user@host:~$ whonixcheck -v
[INFO] [whonixcheck] | Whonix-Workstation | Thu Nov 23 06:18:08 UTC 2017
[INFO] [whonixcheck] Input Detection: INPUT_AUTO=true CLI=true GUI=false
stdin connected to terminal. Using cli output. Not using gui output.
Alternatively, if want to run from command line, but still use the graphical user interface for input, you could add to command line: --gui
[INFO] [whonixcheck] Root Check Result: Ok, not running as root.
[INFO] [whonixcheck] Pin torproject.org certificate: disabled.
[INFO] [whonixcheck] Qubes Settings Test Result: Skipped, because Qubes not detected.
[INFO] [whonixcheck] Check Kernel Messages Test Result: Found nothing remarkable, ok.
[INFO] [whonixcheck] Check whonixsetup Result: done, ok.
[INFO] [whonixcheck] Check Package Manager Running Result: None running, ok.
[INFO] [whonixcheck] check network interfaces Result: Ok.
[INFO] [whonixcheck] Tor Check Result: Not running on Whonix-Gateway, ok.
[INFO] [whonixcheck] Tor Config Check Result: Not running on Whonix-Gateway, ok.
[INFO] [whonixcheck] Tor Pid Check Result: Not running on Whonix-Gateway., ok.
[WARNING] [whonixcheck] Tor SocksPort Reachability Test Result: Unreachable! Failed to connect to host. Gateway likely reachable, but Tor service likely not started. Either user has run sudo service tor@default stop or Gateway is still booting and has not started Tor service yet. (curl exit code: 7 | curl status message: [7] - [Failed to connect to host.])
[ERROR] [whonixcheck] Tor Bootstrap Result:
Tor’s Control Port could not be reached!

Troubleshooting:

  • Confirm that Whonix-Gateway is running.
  • Run whonixcheck on Whonix-Gateway and confirm success.
  • If you’re running multiple Whonix-Workstations simultaneously, confirm that separate IP addresses are configured (see https://www.whonix.org/wiki/Multiple_Whonix-Workstations).
  • Rerun whonixcheck here in this Whonix-Workstation.

(Technical information:)
(Code: 255)
(tor_bootstrap_timeout_type: none)
(tor_bootstrap_status: Socket error: [Errno 113] No route to host)
(check_socks_port_open_test: 7)
(Tor Circuit: not established)


#8

I haven’t used virtualbox in a long time so I can’t reproduce this.

Are you sure gateway is ok? Next time you experience this, run whonixcheck in the gateway, and then after that, run it again in the workstation.

Could the gateway VM be entering suspend mode?

Are your activities in the Workstation modifying its firewall in any way?

Do you have applications configured to use port 9052?

Do you have slow hardware or is your system under stress when this happens?


We can get more detailed information by running:

bash -x whonixcheck --function check_tor_socks_port_reachability
bash -x whonixcheck --function check_tor_bootstrap

BUT don’t paste results without sanitizing (your VM names might appear in the output).


#9

Is it possible open bazaar2 could be the problem?


#10

It gets stranger, as I can surf with Tor, but then I try system > tor downloader & I get error saying Tor not fully bootstrapped.:thinking: Just found that odd.

I will try to sanitise, but is a lot of script to go through & not sure.

Ty for your time.


#11

HI Fyah_Burn

You may also want to try asking for help on the Tor Project’s IRC channel. Information on how to join the channel as well as other support resources can be found here:

https://www.torproject.org/about/contact.html.en


#12

Depends. How did you configure its Tor Control Port?

I don’t know how OpenBazaar behaves but if it opens up many connections to the Control Port, Whonix will stop allowing new connections.


#13

OpenBazaar + Whonix is not well documented.

A workaround might be to increase max control port connections as described here for Whonix 13. Whonix 14 increases limit from 5 to 50.

BUT if OpenBazaar is flooding control port with requests, it would be good to know why. Perhaps, Whonix is filtering the requests and causing OpenBazaar to repeatedly send the same request.


#14

Thanks for the suggestion. I edited the control port limit, but still getting bootstrap errors.


#15

That wouldn’t be surprising if OpenBazaar is flooding the port.

If you’d like to troubleshoot, in Whonix Gateway, take a look at:

/var/log/control-port-filter-python.log