[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix->Tor->Proxy->internetoftubes help

So I’ve tried following the guide https://www.whonix.org/wiki/Tunnels/Connecting_to_Tor_before_a_proxy but I haven’t managed to tunnel the proxy it seems that I’m always using tor to connect, for now I’ve tried the easy FoxyProxy method and the proxychains method keep getting random ip’s and not the socks 5 proxy I wanted,what could be the issue?

Will edit and improve tomorrow morning, thank you for now.

proxychains, see this thread please:
https://forums.whonix.org/t/proxychains-tor-help-needed


FoxyProxy - https://www.whonix.org/wiki/Tunnels/Connecting_to_Tor_before_a_proxy#Tor_Browser_Proxy_Configuration - @HulaHoop does this still work?

1 Like

Yes tested and working.

1 Like

Testing out everything from the link and all possibilities will come back afterwards thank you angel Patrick!

While testing i found that this command isn’t working
whonix.org/wiki/Tunnels/Connecting_to_Tor_before_a_proxy#Tor_Browser_Example

uwt -t 5 -i 10.152.152.10 -p 9153 ~/tor-browser_en-US/App/Firefox/firefox --profile ~/tor-browser_en-US/Data/profile
UWT ERROR: command is missing.

another, why did i got this on su mode

kdesudo kwrite /etc/uwt.d/50_user.conf
No protocol specified
kdesudo: cannot connect to X server :0

Would these instructions still work if one removed Tor Browser proxy settings first
( https://www.whonix.org/wiki/Tor_Browser#Remove_Proxy_Settings )
and then combined these instructions with the Tor Browser change proxy settings instructions
( https://www.whonix.org/wiki/Tor_Browser#Change_Proxy_Settings )
?

1 Like

Technically when you install foxyproxy you “patch” the original default proxy and its settings and apply a new advanced configuration instead.

1 Like

Yes, but would it be wrong to apply https://www.whonix.org/wiki/Tor_Browser#Remove_Proxy_Settings first before that?

1 Like

I just remembered from reading over the local connection section.

Web HTTP(S)/SOCKS proxies have different instructions and will not work with these steps, see Tor Browser Proxy Configuration.

FoxyProxy is the only way to use external proxies in TBB.

1 Like

Okay still haven’t managed to connect through a proxy,I’ve read all the links and tried all the stuff from the other thread with no success. what could be the issue? Fighting with this for some days now

Learning and applying this is very much worth trying:
https://www.whonix.org/wiki/Support#General_Advice

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]