Whonix starts first, but after first Screen - Blackscreen


every time i want to start Whonix, it starts in Normal mode, loads only 2 things (RAM and something other) and then there is blackscreen. This on gateaway and workstation. And I cant shut it down, only close.

Does anyone know what my problem is?

Hi 124Freibier

Its difficult to tell.

If none of this helps could you please try creating a Debian VM in VirtualBox and see if you have the same issue.

Edit by Patrick:

See https://www.whonix.org/wiki/VirtualBox/Troubleshooting#Black_Screen

1 Like

No, how do I verify the Images?
I’ll try opening the console when I have time later.
RAM shouldn’t be a Problem, i have 16GB and only thing thats opened is VirtualBox when I use it.

Same here. Working install fails to boot reliably after upgrade from VB5 to VB6. Could be VB and/or kernel related. Usually corrects itself if I reboot.

Host is Manjaro(arch) , stable branch, XFCE edition. Kernel 4.19.16-1

I have VirtualBox .04 and have 32GB ram. I downloaded both Whonix XFCE and CLI and both versions of the gateway are black screens right after the grub screen.

I tried opening a different console inside the VM and nothing.
I verified the downloads and still an issue.
I upgraded the RAM to 8 GB on the CLI gateway and still a black screen

I downgraded to VirtualBox 5.22 and the ova files give a OES error.
I reinstalled VirtualBox 6.04 and the OVA files import fine, but the same black screen.

Hi infosecwriter

A few users have reported this issue. Unfortunately its very difficult to troubleshoot without more information. Would you be up for a little troubleshooting/ experimentation? You could start by searching for similar issues with Vbox and try some of the solutions. For example, search for key words:

VirtualBox blackscreen at boot

One of the search results returns this thread which has a few solutions you could try out.


1 Like

VT-x is enabled in the bios. I ran all the goodies to disable Hyperv and it is not found in this OS. It seems to be an issue with all the Linux (32/64 bit).

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity\Enabled=0 also didn’t work

1 Like



1 Like

A post was split to a new topic: blinking underscore

I had this before as well, however with recent Whonix it is no longer a problem.
I don’t think it was a Whonix problem either. it was a kernel/virtualbox issue that has been fixed a while back then reintroduced somehow then fixed again.

It was discussed on the virtualbox forums but I can’t seem to find the link anymore

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]