[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix on Mac m1 Max Problem with sdwdate

in Whonix-Gateway-XFCE
In sdwdate logs:

  • terminal_emulator_window_title=‘sdwdate Log Viewer’
  • /usr/libexec/helper-scripts/terminal-wrapper ‘sudo --non-interactive /usr/bin/sdwdate-log-viewer’
    sdwdate-gui : TTY=pts/0 ; PWD=/run/sdwdate-gui ; USER=root ; COMMAND=/usr/bin/sdwdate-log-viewer
  • sdwdate reports: Preparation not done yet. More more information, see: sdwdate-gui → right click → Open sdwdate’s log
    ____ ### START: ### /usr/sbin/anondate-set
    ____ INFO: Status file ‘/run/sdwdate/tor_certificate_lifetime_set’ does not yet exist.
    ____ INFO: Running anondate-get…
    ______ ### START: ### /usr/sbin/anondate-get
    ____ INFO: anondate-get returned Tor consensus middle range time or minimum time.
    ____ INFO: The ‘anondate-get’ time_result is earlier than the current system time, ok. Not setting clock backwards.
    ____ ### END: ### Exiting with exit_code ‘3’ indicating ‘Setting time using anondate either not possible or not required.’.
  • sdwdate reports: Preparation not done yet. More more information, see: sdwdate-gui → right click → Open sdwdate’s log

What I need to do to fix this?

Incomplete log.

See Pasting Logs for Support.

Does https://www.whonix.org/wiki/Reporting_Bugs#Out_of_Scope_Issues apply?
Or sdwdate never completes?

sdwdate never completes

A general connectivity issue? No connectivity is functional or only sdwdate isn’t functional?

If there is no connectivity whatsoever, see
Unsuitable Connectivity Troubleshooting Tools

If sdwdate is the only broken thing, full sdwdate log is required.

I found a solution, I just had to set the system time a couple of hours earlier

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]