Whonix on Mac M1 (ARM) - User Support (still unsupported at time of writing)

Anyone know how to remove the monero-package from the package system without altering the dependencies? Then i can build from source for ARM64.

Are you sure that’s even an issue?

It’s already considered in the source code (dummy-dependency-hardened-monero-gui). Untested but has a good chance that would work.

Well when i try to purge out the package it will also remove non-qubes-whonix-workstation-xfce and non-qubes-whonix-workstation-xfce.


Not sure what you ment with this? More info needed to test your idea.

Invalid test. Please don’t start with the presumption there will be an issue without an actual build issue.

That wasn’t an issue for previous builds by others in this forum thread and probably won’t be one now. This isn’t the first port of Whonix to another architecture:

This is unrelated to development. More of meta packages usability issue / user support:

In short: install package dummy-dependency-hardened-monero-gui first.

For developers to look into it, search the source code for:


  • Search the Source Code
    • But download Whonix instead of Kicksecure source code.
    • Search
      • Kicksecure

    • Replace:
    • Whonix

    • Search
      • kicksecure

    • Replace:
    • kicksecure

UTM can make use of the Apple Virtualization Framework so this would allow running the official release of the Tor Browser with relatively small overhead on Whonix on M1 Macs.

Running Intel Binaries in Linux VMs with Rosetta | Apple Developer Documentation

That’s good to know. However hopefully not needed / this being a better solution:
ARM64 Tor Browser

Needless to say that this might be very useful for all sorts of other software unavailable for ARM64.

Been trying to rebuild this project and get some errors now on the build.


Here is the output of the build log.
Not sure what makes the build to fail.

Outdated git tag.

Can I download ready .utm whonix files for M1 MacBook, without building?

No. If that changes, these will be easily found on the website.

Thank you, seem i have missed a bit while i was away. Tried to build the project under build number as the new build documentation require. But got into some problems. I thought Tor browser would work now.


This is the build log trying to build it without using --tb open
But it did not work and got some errors. I did another build with --tb open and when i tried to start up Tor browser it was not installed. While trying to install it through the finished build it fails to download. Even when i try on CLI to use the command update-torbrowser it will fail to download.

So do we still need to manually download and install torbrowser? or have i done something wrong?

Thank you for your time, been away from this for a while so need to kinda get into this again.

ARM64 Tor Browser was signed with a new key.

gpg: keybox ‘/home/user/.cache/tb/gpgtmpdir/pubring.kbx’ created
gpg: /home/user/.cache/tb/gpgtmpdir/trustdb.gpg: trustdb created
gpg: key 6AF15D1E45FDCEC9: public key "Heikki Lindholm " imported
gpg: Total number processed: 1
gpg: imported: 1
gpg: Signature made Fri 10 Jun 2022 10:41:23 AM UTC
gpg: using EDDSA key 17646366EFF82DB13E5CCDB23A557859C963442B
gpg: Can’t check signature: No public key



That I don’t have that OpenPGP / gpg public key and neither can find it online.

ARM64 Tor Browser Maintainer

It must be possible to perform this manually before it can be automated in tb-updater.

I see, well update us when and if there is any changes to this.
Guess for now i need to do manual download for torbrowser like before.

  • Fixed tb-updater (with the new signing key) is now available in all Whonix repositories. Available after updating.
  • Additionally, optionally git tag has been created just now, which in theory should work but in practice is untested.

Tried to build both the gateway and the workstation with the git tag and the build failed right away when i tried to build it.


1 Like

I saw that a new update came out with the git tag and tried to build from that. But that failed as well. So i cannot build the project anymore on apple silicon based macs now. At least not on the newer tags.


1 Like

Yeah. That’s currently broken due to refactoring. This is the issue: