[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix on ESXi 6

Hello

I’m trying to run whonix gateway on ESXi 6. I have read in the f.a.q. that’s tested to ESXi 5.5. I have created a default machine with debian OS as template and uploaded the .vmdk
Now i start the machine and i soon get a kernel panic. I also tried the 586 in the boot option of whonix but i always get the kernel panic.
I have tried to uncheck ‘expose NX/XD’ flag and i also played with the CPU/MMU visualization.

Still no luck. As it runs fast over the screen i can’t see where it stops. I have made a screenshot.

Maybe someone can get me a hint what’s wrong?

https://www.whonix.org/wiki/VMware is unsupported. ( https://www.whonix.org/wiki/FAQ#What_do_you_mean_by_unsupported.3F )

Try running Debian jessie first. See if the works. Debug that first as per https://www.whonix.org/wiki/About#Based_on_Debian you get access to a bigger support community.

I am also facing the exact problem. Silent73, were you able to install Debian jessie as Patrick recommended. Any success or updates on this?

hello goldy

i was able to install debian jessie. i followed the instructions to compile whonix but i always get some errors i couldn’t solve.
so i gave up after a week.
i don’t use whonix right now maybe at later versions when it will compile.

Same situation here. Able to install debian jessie absolutely fine but whonix doesn’t seem to bootup at all. Tried among different guest OS options in settings, but whonix kept failing, with different messages.

Anyways, I want to use whonix and cannot change my esx 6 infra, so what alternatives or workarounds do I have @Patrick. I intend to use only whonix gateway for my custom linux system on esx6.

Does any following workaround seems sensible ?

ESX 6 (windows(virtual box(whonix)))
ESX 6 (Ubuntu server(KVM(whonix)))
ESX 6 (ESX 5.5(whonix))

VMware ( https://www.whonix.org/wiki/VMware ) is unsupported.
( https://www.whonix.org/wiki/FAQ#What_do_you_mean_by_unsupported.3F )

Only option is to use a supported platform:
https://www.whonix.org/wiki/Download

Sorry to bump this old thread but I’ve just solved this in my own ESXi 6 environment, and since this is the top result for searches on this issue I figured I should post it here. I went through the same struggles as the previous posters and then stumbled randomly onto a solution:

  1. Download the whonix-gateway OVA file for Virtualbox
  2. Import the OVA into VMWare Workstation (I used 12.1.1).
  3. It will throw an error, just click Retry and it will complete.
  4. Without ever powering it on, export the VM from VMWare Workstation into OVF format.
  5. Import that OVF into your ESXi6 environment (I have ESXi 6.0.0, and I imported through the thick client).

The machine boots properly! I just finished configuring it and it’s working, I’ve got some VMs now that are nicely isolated and can only use TOR :slight_smile: (To be clear, I am only using the gateway, not the client VM. I didn’t try out the client VM at all as I don’t need it for my purposes.)

Hope this helps

1 Like

Thanks a lot. It works as described. Now i have the gateway and the workstation up and running in ESXI 6.
One issue the low resolution in the workstation (1024x768) but i will try to find the solution to this.

Don’t worry about that. ( https://www.whonix.org/wiki/Forum_Best_Practices#Bumping_old_Threads_is_Okay )

Resurrecting again…I recently installed ESXi and several Debian 8.1 Jessie VMs. I had no problem installing VirtualBox and importing the ova files. They seem to boot fine and everything. The only issue I am having at this time is it appears that my mouse is not syncing with the system. Unclear if it is a resolution issue or something else. I am still working on it .

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]