Whonix is a bit laggy

Over the years I have used Whonix on multiple systems via Virtualbox. On every machine I have noticed the same thing: “a bit of lag”.

It happens when I type: I can notice the characters come up after a short delay, maybe only 50ms but noticeable nonetheless.

The interesting thing is that the Whonix-Gateway-XFCE does not have this problem. If I open a terminal there and start typing, it feels smooth.

What gives?

Resources? Do you have enough RAM and CPU available?

That’s a feature, not a bug. :wink:
It’s an anonymity feature which is creating this issue.

The context is:

The the defense is:
Keystroke Deanonymization - Whonix chapter Kloak in Whonix wiki

Kloak is the cause of the observed behavior.

Can be recognized as a bug. But as a cannot fix or patches required.
(Bug Reports, Software Development and Feature Requests chapter Contributions in Whonix wiki)

Ideally we would have keystroke anonymization using Kloak and at the same time no user visible delays while typing but that seems unlikely given the current support status of kloak upstream.

1 Like

Thanks :slight_smile:

For future readers, to stop it: systemctl stop kloak

To never start it again: systemctl disable kloak