[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Instability

I wonder if it’s just me or whether other people have this problem, but I often get a “guru meditation” error, particularly with workstation (not very often with gateway), and particularly during installation, despite increasing the system and display RAM on the vm (in Virtualbox’s settings). It happened again just now with a new install of 9.3 but it has often happened with 9.2. It doesn’t always happen at the same point and is somewhat intermittent. Usually I just delete the vm and start again.

The last such crash occurred when it was half-way through the tor connection part of the initial Whonix check. Here is the end of the log:

00:09:47.223345 FF: 00 00 00
00:09:47.223355 !!
00:09:47.223356 !! {vgagr}
00:09:47.223357 !!
00:09:47.223361 VGA Graphics Controller (3CF): GR index 3CE:05
00:09:47.223365 GR00:00 GR01:00 GR02:00 GR03:00 GR04:00 GR05:50 GR06:05 GR07:0F GR08:FF
00:09:47.223403 !!
00:09:47.223404 !! {vgapl}
00:09:47.223405 !!
00:09:47.223408 read mode : 0 write mode: 0
00:09:47.223414 set/reset data: 00 S/R enable: 00
00:09:47.223420 color compare : 00 read map : 0
00:09:47.223426 rotate : 0 function : 0
00:09:47.223432 don’t care : 0F bit mask : FF
00:09:47.223438 seq plane mask: 0F chain-4 : on
00:09:47.223445 !!
00:09:47.223445 !! {vgasr}
00:09:47.223446 !!
00:09:47.223450 VGA Sequencer (3C5): SR index 3C4:00
00:09:47.223454 SR00:03 SR01:00 SR02:0F SR03:00 SR04:0A
00:09:47.223476 !!
00:09:47.223477 !! {vgatext}
00:09:47.223478 !!
00:09:47.223482 Not in text mode!
00:09:47.223485 !!!
00:09:47.223569 emR3Debug: rc=VERR_TRPM_DONT_PANIC
00:09:48.224529 Changing the VM state from ‘RUNNING’ to ‘GURU_MEDITATION’.

The system RAM was 1024MB and the display RAM was 128MB

Any ideas? Would it help if I attached the entire log?

I don’t think anything Whonix does can be responsible for such kinds of bugs. Eventually anything that the linux kernel does.

But in any case, since the error is happening in VirtualBox… Guest operating system such as Whonix whatever they do should by design not be able to crash the VM on the host.

The full log wouldn’t help me, but if you are interested to get this bug fixed, see:
https://www.virtualbox.org/wiki/Bugtracker

Thanks for your reply.

Before I do a bug report I’d like to gather some more information, since it might not be Whonix. I was installing on Ubuntu with the very latest Virtualbox from the Virtualbox site. I’m going to try it on a fresh Debian host with the default Virtualbox from apt-get.

I was facing this problem. When you importing whonix your cache is filled up. In other words when you installing whonix your computer not have enough free ram space.

After you finish importing whonix gateway and workstation type: free -m to see how many free RAM space you have.

You can free cached memory by restarting pc or type:
sync
sudo /sbin/sysctl vm.drop_cashes = 3

After this begin installing whonix, and you should not meet guru now :slight_smile:

Hello ilovefruits, thanks for the information!

Whonix is rock-solid so far, after 18 hours of intermittent use, on a new install of Debian on the same computer. “free -m” says that there is 1.5GB free.

I doubt that the amount of system RAM is the issue in my case, since the computer has 4GB of RAM.

On the Ubuntu host OS (same computer), Whonix was unstable from the initial installation, with VM settings at their default values. Only later did I increase the RAM on the VMs to try to fix the crashes but it made no certain difference either way.

I suspect some peculiarity related to my computer, perhaps the video card, since my searching online did not turn up anyone else reporting such instability of Whonix.

I note that the current setup is the second installation of Debian, with KDE selected as the desktop UI. The first time I installed Debian on this computer, with the default desktop (Gnome), it gave an error near the end saying that my graphics card was not capable of running all the features of Gnome. Considering that the log I posted above reported a crash when the graphics controller was being configured, it’s possible that swapping out the graphics card would have been a remedy.

EDIT: I should add that the problem appears to be between Virtualbox and my graphics card rather than in Whonix.

I got same problem guys.

I’ve met Guru a lot of times with whonix 9.x. Never happened in guru 8.x. I’m using whonix gateway only.

First time it’s happened i’ve reinstalled whonix gateway. Really don’t remember why it’s started.
but now i don’t get. I’ve worked 3 hours today, now i start my linux -> whonix gateway… and while I was waiting 4 automatic whonixcheck, guru came out of the blue.

Turned off the vm, started again… happened again, this time way b4 whonixcheck. Reboot again… and now it’s starting but guess what, i try whonixcheck and I got somethin like:

[WARNING] whonixcheck is been aborted [SIGTERM]

BUT whonixcheck goes well anyway… checks everything and says he can’t control the apt-get updates. And finally says an error about GPG that the key is expired or similar.

Okay well… i turn the vm off and I say, let’s go on the forums then, and here i’am.

I’ve tried 1 more time. Now after 5 sec after boot Guru crashes everything again.

Really don’t know why this is happening. In the last week everything went smooth, even today…

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]