[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix in IOS Help


#1

I recently downloaded a fresh copy of virtualbox and whonix as per the virtualbox instructions on this site. Everything was set up and running smoothly initially, until I installed the tor browser update on the whonix workstation. Now, when I boot up the gateway, and then the workstation and click “tor browser” on the workstation, the tor browser won’t load at all. Won’t even start. My questions are as follows:

How do I get the tor browser do start? Is something wrong now?

How do i ensure that the gateway is routing traffic to the work station? Does virtualbox do this for me? Nothing else required except follow the brief instructions contained on this site?

Running my VPN in the background. I have PIA VPN, and it loads up upon booting up the computer and before I even open up virtualbox. Is this okay?

Thanks!


#2
  1. For more output you can try to launch the tor browser directly from the folder in verbose mode i.e. “./start-tor-browser -v” . Also take a look at the log, i.e. “sudo journalctl”, or use “sudo journalctl -f” and then try to start the browser.

  2. Normally just starting the two VMs should be sufficient and you don’t need to setup anything else. The Tor browser problem is likely not related to any connectivity issue. You can also use whonixcheck, any other command which needs internet access or wireshark to see if there are any network problems.

  3. Should be. In case you don’t get any connection to Tor you should test it without a VPN.


#3

https://www.whonix.org/wiki/Tor_Browser/Advanced_Users#Debugging


https://www.whonix.org/wiki/Tunnels/Connecting_to_a_VPN_before_Tor#Use_a_Fail_Closed_Mechanism