Whonix GW daisy chais connection problem

Hi, i connected 2 whonix gw in daisy chain. 2nd GW is unable to connect with TOR - bootstraping hangs at 2% with message: “unknown bootstrap TAG. In most cases this is harmless. Please reprot this” . I checked tor logs and i noticed below messages:
[warn] Pluggable Transport process terminated with status code 15
[notice] Bootstrapped 1% (conn_pt): Connecting to pluggable transport
[notice] Bootstrapped 2% (conn_done_pt): Connected to pluggable transport
and message flood “general SOCKS server failure” and [notice] New control connection opened…
Can you tell me what cause that socks connection errors? I misconfigured sth? Traffic is blocked by iptables?

Guyes, I’m moron… Yes - i fu*cked up WAN configuration by removing from interfaces.d gateway IP for WAN NIC. I assignet gateway IP to and it worked. I totally forgot that WAN needs a gateway to get internet connection and start talking to the world… I always use DHCP - that’s why i completly forgot about it… Now it’s time to clean up a configuration mess for workstation to she could also communicate with no problem…

Guys i have problem with configuration. Gateway worked,tor bootstrapped", but i can’t get working Workstation. I think that the problem is in fact that I changed IP directectly in default confg files, intead via user config file, so I didn’t replaced network configuration in all necessery files.
Can you explain me pls which one file and variables should I edit to get it working?

Network: Changing the complete /16 - #5 by Patrick

Command git clone --depth=1 --branch --jobs=4 --recurse-submodules --shallow-submodules returns error could not find remote branch 15, not found in upstream origin…


Damn, there are a lot of them… Yeah, I skipped over 90% of them, so no wonder why it doesn’t work…

Patrick, what about files like /usr/share/anon-apps-config/kioslaverc? Can I edit them directly without messing with dpkg interactive conflict resolution dialog during system update?

I can’t change IP for /usr/lib/helper-scripts/tor_bootstrap_check.bsh . I created 50_user.conf in /etc/whonix.d, dropped GATEWAY_IP variable, rebooted vm and still got… :confused:

Only files in /etc have this issue.

Files in other locations are overwritten when Whonix packages are upgraded.

Working around that would require development.

Where exactly?

I improved that source code comment in git master just now.

Error logs for Sdwdate… Uh, I see… I skipped 50_user.conf for sdwate… Thanks, your imrpoved comments helped me find the problem…

Patrick, I found problem… Tor@defailt service doesn’t want to work most likely because of warn: “Could not bind to[port no.] Cannot assign requested address”. I suspected a file tor-defaults-torrc.anodist, so I deleted its content and leave only 50_user.conf. It worked, so the problem is that that both files are loaded together instead just ignore the first one when custom config exists. Where can I disable tor-defaults-torrc.anodist so that it is not loaded by tor service?


You could have found that by grepping Whonix source code for:


Ok, it finally worked… Thank you so much for help… This time I had problem with connection on wokrstation by i solved it by changing my strategy and changed LAN configuration on 1st GW instead 2nd and of course I changed too iptables’s acces rules and WAN configuration on 2nd GW, LAN left as is and it worked right away …Why didn’t I think about it eralier, ugh… As always I had to get things more complicated.