[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix Gateway Systemcheck failure

Hello,
Context: Setting up Whonix KVM on PopOS22.04 host machine
Issue: systemcheck errors on Whonix-Gateway.

Debugging Info:

pastebin[dot]com/hh1sUCf1

Screenshot:

imgur[dot]com/a/XlykA9C

@Patrick I ran the following command:

sudo /usr/libexec/anon-gw-anonymizer-config/tor-config-sane

here is the output:

pastebin[dot]com/kk5PgTFJ

Again, thanks for taking the time to look at this. Much appreciated!

Please avoid pastebin.com as it shows a captcha when attempting to read. Please also note:

The systemcheck console output looks good. Only INFOs. So no critical issue found.

There’s an issue with the systemcheck GUI output window popup.

I’ve pushed some changes to the systemcheck and msgcollector git repositories which are already available in the Whonix testers repository.

Might still be a similar issue to very long systemd journal log breaks systemcheck.

If you wish to debug further:

  1. Please try this test (documented just now): https://www.kicksecure.com/wiki/Systemcheck#Arg_Max_Check

  2. Post output of systemcheck in debug mode with GUI.

    systemcheck --cli --gui --debug

Another reply of mine probably coming soon.

That also looks good.

Another reply of mine probably coming soon.

The following minor issue (which is just about creating a lot with the error or not) was fixed:

/usr/libexec/msgcollector/msgcollector: line 68: /run/systemcheck/.msgcollector/msgdispatcher-error.log: Permission denied


Jul 08 22:41:01 host /usr/libexec/gdm-x-session[1112]: status_changed unexpected error:

As long as there are no sdwdate-gui issues, this is fine.

Jul 08 22:40:45 host /usr/libexec/gdm-x-session[1107]: tor-config-sane unexpected error:

This one I am not sure about yet.

Why is tor-config-sane run under gdm-x-session? It started by a systemd unit file /lib/systemd/system/anon-gw-anonymizer-config.service which is independent from GDM.

But since everything is working, it cannot be that bad.

Also /usr/libexec/anon-gw-anonymizer-config/tor-config-sane now in testers repository has easier to produce debug output.

On Whonix-Gateway, please run and post the output here:

sudo bash -x /usr/libexec/helper-scripts/repair-torrc

(Also works with Whonix stable repository.)

Also useful:

Check Systemd Journal Log of Current Boot

Thanks for sharing those links. I’ve been looking for better alternatives to share pastebins and screenshots :slight_smile:

Good news, It works now!
anonfiles[dot]com/Ha45nfwdyd/Screenshot_from_2022-07-09_14-18-24_png

This command fixed it:

sudo bash -x /usr/libexec/helper-scripts/repair-torrc

After running the command I ran another systemcheck and this time it passed as shown in the screenshot above.

Thank you @Patrick for all the help and detailed replies, couldn’t have done it without you! Much appreciated

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]