[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Gateway does not connect to the internet

Downloaded the whonix gateway ova file via torrent from https://www.whonix.org/wiki/Download.
I have installed VirtualBox on my laptop running Windows 7 Professional that connects to the internet via a wireless router.
I imported the ova file into VirtualBox
I let it run.
After whonixcheck starts I get an error saying network is unreachable.


Even pinging google.com does not work.
I tried customizing the network adapter settings for the 2 adapters I set them both to

But still no luck.
Any idea what I am doing wrong?

I tried customizing the network adapter settings for the 2 adapters I set them both to
Don't do this. Delete those VMs and re-import unmodified ones.
Any idea what I am doing wrong?
Please answer the questions that whonixcheck asked.

This is expected. Whonix-Gateway allows only user “tor” and “clearnet” to access “clearnet” by default and there is no system DNS by default (https://www.whonix.org/wiki/Whonix-Gateway_System_DNS).

I tried withouth modifying adapter settings, it also doesn’t work.
Tor works fine on my laptop.
Tried Arm and it doesn’t work.

Check this chapter please:

Do I have to create a new connection before running Whonix check?

New connection? Not sure what you mean by that. Probably no.

I reinstalled VirtualBox and it started to work. Or at least now it says tor ok. The workstation connected to it has no internet but I think this is a separate issue.

Is there any way to know for sure that there is internet on the gateway?(you mentioned ping isn’t support to work)
I apologize for the newbie questions.

No simple stuff. (There is the clearnet user, but has no DNS by default.) It’s not really needed.

If internet in other VMs is working = internet in Whonix-Gateway is working. And if internet in Whonix-Gateway is working, all that could be in the way is network censorship.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]