[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Whonix Gateway CLI-15.0.1.5.4 and Debian 10.9 as Workstation - Network issues

Greetings,
I imported a fresh Whonix Gateway CLI .ova file on VirtualBox and I tested with a fresh Whonix Workstation XFCE.
Then I decided to use as workstation Debian 10.9 (debian-live-10.9.0-amd64-xfce) installing it in a Virtual Machine.
I followed the procedure described in the following link: https://www.whonix.org/wiki/Other_Operating_Systems#Whonix_.E2.84.A2-GNU.2FLinux-Workstation

In particular, as described in the link, I made a new machine where I attached the .iso file and in the VirtualBox settings for this Debian machine, I set the following:

  • SystemMotherboardHardware Clock in UTC
  • SystemMotherboardPointing DevicePS/2 Mouse (required to disable the USB controller)
  • SystemProcessorEnable PAE/NX (if available)
  • NetworkAdapter 1Attached to Internal Network (important!)
  • NetworkAdapter 1Name (of Internal Network) (important!): Whonix [8]
  • USBUncheck Enable USB controller
  • OK

then I turned on the machine for the installation.

After the installation, I configured the network in this way:
sudo nano /etc/network/interfaces
and substitute the content with:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface, leave as it is
auto lo
iface lo inet loopback

auto eth0
#iface eth0 inet dhcp
iface eth0 inet static
# increment last octet of IP address on additional workstations
address 10.152.152.12
netmask 255.255.192.0
#network 10.152.152.0
#broadcast 10.152.152.255
gateway 10.152.152.10

Then, I edited /etc/resolv.conf by substituting the content with:
nameserver 10.152.152.10

and then I rebooted the Debian machine. I also rebooted the Whonix Gateway.
After the restart of both of them. on Debian machine I tried to execute a curl ifconfig.me and also a sudo apt-get update to check if it is connected, but it is not (indeed I get the popup of Network Manager that says I’m disconnected). Only Whonix Gateway is correctly connected.

Is it possible that on Debian, the settings on /etc/network/interfaces could be in conflict with the Network Manager application? Or for working my Debian machine needs the Tor package to be installed? Or likely I’m missing some further step? (PS: on Debian I didn’t still install Tor Browser, on it there is Firefox ESR).

In all this scenario the Whonix Workstation is kept turned off.

Thank you in advance

1 Like

Hello,
I answered to my question because I found the solution.

On my Debian machine, the interface name was different, it was not eth0 but enp0s3, so, in the /etc/network/interfaces, I substituted eth0 with enp0s3 and then I executed sudo ifup enp0s3. Without restarting the machine, it is possible to test by a sudo apt-get update.

I added this detail in the wiki of the link I attached on my question.

1 Like

Better to use Disable Predictable Network Interface Names instead?

References:

zless /usr/share/doc/udev/README.Debian.gz | cat

Instructions would suggest instead:

sudo ln -s /dev/null /etc/systemd/network/99-default.link
sudo update-initramfs -u

And perhaps reboot.

Untested.

Advantages: closer to Whonix-Workstation configuration. Easier. “Actually” predictable network interface names (at lest inside VMs).

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]