[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix-External.xml doesnt exist

Using

virsh -C qemu:///system net-define Whonix-External.xml

it will show:

error: Failed to open file 'Whonix-Extermal.xml': No such file or directory

Did you download the latest version? These files were named differently before.

yes the latest version im using

testing 15.0.0.6.6 same issue

user@host:~/Downloads$ tar -xvf Whonix*.libvirt.xz
WHONIX_BINARY_LICENSE_AGREEMENT
WHONIX_DISCLAIMER
Whonix-Gateway-XFCE-15.0.0.6.6.qcow2
Whonix-Workstation-XFCE-15.0.0.6.6.qcow2
Whonix-Gateway-XFCE-15.0.0.6.6.xml
Whonix-Workstation-XFCE-15.0.0.6.6.xml
Whonix_external_network-15.0.0.6.6.xml
Whonix_internal_network-15.0.0.6.6.xml
user@host:~/Downloads$ virsh -c qemu:///system net-define Whonix-External.xml
error: Failed to open file 'Whonix-External.xml': No such file or directory

user@host:~/Downloads$
1 Like

Thanks. I see what you mean now. Seems the config file names have changed while the network names inside as documented are as I intended.

Does it work for you now?

nope same thing , no network matching name ‘Whonix-External’ @HulaHoop

I checked the current instructions on my page and it works, but it would give an error if you attempt to re-import it while it exists. I added a warning about that.

how then if previous whonix installed and want just to install new one ,
but i cant due to instructions not working?

cant we add it from create a new VM -> Import existing disk image?
(tried it but not working with me)

If you’re upgrading, just delete the older version with its disk files then only import the new disk with it’s config file. No need to touch the network configs unless I made it clear that there were changes that need them to be removed and reapplied for. This was the case when moving from Whonix 14 -> 15

No because unlike OVMF the VM and its settings are not bundled in KVM and need two separate steps to happen.

Error starting domain: Network not found: no network with matching name 'Whonix-External'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 111, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 66, in newfn
    ret = fn(self, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1400, in startup
    self._backend.create()
  File "/usr/lib/python3/dist-packages/libvirt.py", line 1080, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirt.libvirtError: Network not found: no network with matching name 'Whonix-External'

not sure where is the problem i have even deleted whonix and moved it again but same error.

VMM -> edit -> connection details -> virtual networks

Look for network names. Let me know if anything besides “default” exists. If not you need to import Whonix-External using the virsh net-define command and apply it to actual xml filename.

Aha! Here’s your problem: you still have the old virtual networks which use the virtual bridge numbers the new version need.

I’ve already posted a pinned topic about this when migrating form 14 to 15. You need to remove external and internal then import the new ones otherwise it won’t work.

1 Like

yep solved! thanks :slightly_smiling_face:

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]