[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Crashing Linux Mint, + Programs Don't Run With 3D Acceleration Enabled On Virtualbox

Hi,

I have an issue with Whonix, my host OS is Linux Mint XFCE and Whonix is running in the latest version of VirtualBox.

When using the Whonix workstation it periodically crashes not only Whonix and VirtualBox, but Linux Mint entirely. The screen shuts off, and I’m asked to enter my password to unlock Mint again as if the computer had just turned on (all applications closed and reset also.)

This crash seems to happen most often when the hard drive is in heavy use (most common when I’m copying files to an external hard drive) or when media is being played back in VLC.

I read somewhere that this may be caused by 3D acceleration being enabled in the settings. However, when I disable it, very few applications are able to run in the workstation, including the terminal emulator. I either get a message stating “Failed to execute (application name) Input / Output error” or the application just doesn’t open at all.

Some applications however work perfectly either way

Turning 3D acceleration back on immediately fixes all the applications, which run flawlessly again.

What’s the best way to fix both of these issues? I would prefer to leave 3D acceleration off due to the security risks that have been mentioned.

Update: I’m able to run a different terminal in the Whonix workstation that gives the following error when one of the programs is ran:

“OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.”

I do not understand what is causing this or why the 3D acceleration is needed?

I am able to make a second workstation that runs without 3D acceleration just fine. Of course, I do not have all of my software and files, and would prefer to focus on fixing this instead of starting over with a new workstation.

I have also tried updating Linux Mint, updating Whonix, updating software packages installed in Whonix, and switching graphics drivers.

Finally, I found this in my Linux Mint syslog around the time the crash happened:

xfce4-notifyd: Fatal IO error 11 (Resource temporarily unavailable) on X server :0,

at-spi-bus-launcher[1509]: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server “:0”

Hi,

I have an issue with Whonix, my host OS is Linux Mint XFCE and Whonix is running in the latest version of VirtualBox.

When using the Whonix workstation it periodically crashes not only Whonix and VirtualBox, but Linux Mint entirely. The screen shuts off, and I’m asked to enter my password to unlock Mint again as if the computer had just turned on (all applications closed and reset also.)

This crash seems to happen most often when the hard drive is in heavy use (most common when I’m copying files to an external hard drive) or when media is being played back in VLC. A good amount of RAM is available to both Whonix and Linux Mint.

I read somewhere that this may be caused by 3D acceleration being enabled in the settings. However, when I disable it, very few applications are able to run in the workstation, including the terminal emulator. I either get a message stating “Failed to execute (application name) Input / Output error” or the application just doesn’t open at all.

Some applications however work perfectly either way

Turning 3D acceleration back on immediately fixes all the applications, which run flawlessly again.

What’s the best way to fix both of these issues? I would prefer to leave 3D acceleration off due to the security risks that have been mentioned.

Hi JainJude,

welcome to Whonix and thank you for your question.

Whonix is a compilation of software and not modify components on that level. If you like to debug that issue, you’d need to remove the Whonix specific part of your question and then redirect these questions in places with people specialized in this. To learn more what this means, see:

Unfortunately, I don’t have a better answer than this. Perhaps someone else has a better answer than me. Please let us know if you figure something out.

Since you are on a Linux Host you should try KVM with 3D acceleration. It is higher performing and designed to be secure.

Untested but recent improvements in Whonix VirtualBox 15.0.0.9.4 - Testers Wanted! might have fixed this. Please try in combination with VirtualBox version 6.1.4 or higher.


A Whonix support forums thread with 3D issues which were fixed eventually: 3D Acceleration not working in Whonix VMs

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]