[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix connection super slow since 2 days


#1

Hello

I keep always both workstation and gateway updated if that could be the issue…

But it’s from 2 days that internet in whonix workstation is almost impossible to use. I connect with whonix gateway via VPN.

My VPN speed test result: down 21 mbs up almost 3 mbps.

Right now for example I’m updating with apt-get dist-upgrade on whonix workstation… download speed is 15 /kbs… this has never happened. Everything is too slow!

Often the webpages dont even load. I’m getting crazy here… what the fuck is happening?

Could be that my VPN provider is trying to block tor? Is it something else??


#2

Good day,

Did you already try restarting Tor?

Have a nice day,

Ego


#3

Yes of course I tried with the usual command on whonix gateway: sudo service tor restart
Also rebooted both workstation and gateway multiple times


#4

okay so I also tested tor browser bundle after my vpn connection and is working good. So this is definitly a problem given by whonix. Is it possible that is downloading something in background or something like that?


#5

–>

sudo service tor@default restart

#6

Tried that one too without solution… btw my test with a vpn give me like 22mbps speed so that is not the problem…
Same issue :frowning: continuing with this problem

I get 1 error on whonix gateway I see:

clocksource tsc unstable (delta = -552348022 ns)
switched to clocksource acpi_pm

Could be this the issue?

If it continues to work like this do you think a reinstall can help? I’m scared to be infected by some malware at this point since I see no explanation on this


#7

Could be. Is the clock in that VM right (plus/minus) ~ 10 minutes (in UTC)?

Re-install not strictly required but testing separate, freshly imported VMs would be a useful test.

No need because of that. Sophisicated malware will very unlikely be trivially detected through arbitrary error messages or strange issues. See:
https://www.whonix.org/wiki/FAQ#Should_I_be_concerned_about…_.3F


#8

In fact I thought that this might be the issue since I basically closed my laptop while working with those 2 VMs and linux locked the session.

I did this multiple times so at first I thought that must be the reason the clock is out of sync.

But the problem remained after I reboot my whole system and made sure that all clock were in sync.

Then I tried to change that default etc/utc timezone setting in both whonix… didn’t work and + I got an error during whonix check.

So I set back again everything in etc/utc like instructed and no more errors…

Now the connection works sometimes is superslow, sometimes is crazy fast.

I’m not sure. My host clock system matters? If that’s case the strange thing is that until a few days ago I never had problems


#9

#10

Its probable that your Entry guard is temporarily overloaded. Try erasing Tor’s state file and reconnect.


#11

I am not sure this can ever be an advice that should be made. Because adversaries could make the legit guard relays slow on purpose so the user is choosing a new one, and a new one, until the user chooses on under adversary control.

Perhaps try bridges.


#12

You’re right. Disregard the bad advice. Using bridges defends against throttling/blocking Tor by evading DPI firewalls.