[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix check error 125 when checking for package updates

For the last few days I have been getting an error 125. Whonix check says that it can’t check for updates automatically and that I need to do so manually (with sudo apt-get update && sudo apt-get dist-upgrade).

This is over the course of several days, rebooting and using whonix from multiple locations. So I don’t think this is the fault of a bad exit node.

Did you try manually updating?

Yes, I did try doing the update manually. When I ran “sudo apt-get update && sudo apt-get dist-upgrade” the message I got back was “0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.”

By the way, this is the exact error I get with Whonix check:
WARNING: Debian Package Update Check Result: Could not check for software updates! (apt-get code: 125)

There must be some error during manual apt-get update. A line starting with E: or W:. That’s what you have to fix.

This is the output when I do “sudo apt-get update”. I don’t see any lines beginning with E: or W: Every line begins either with Hit, Ign, or Get.
** NOTE: I abbreviated the output because the forum gives me a message that new users can’t post from than 5 links **

user@host:~$ sudo apt-get update
[sudo] password for user:
Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.us.debian.org jessie InRelease

Get:1 http://www.whonix.org jessie/main Translation-en_US [154 B]
Ign http://www.whonix.org jessie/main Translation-en_US
Get:10 http://www.whonix.org jessie/main Translation-en [154 B] Reading package lists… Done

For debugging…

Open /usr/lib/apt-get-wrapper with root rights.

kdesudo kwrite /usr/lib/apt-get-wrapper

Below #!/bin/bash, add:

set -x

Save.

Then start whonixcheck from terminal (Konsole). Then we should be able to see what is causing whonixcheck to think there is something wrong.

I tried doing that (putting the set -x into the file). I then ran whonix check from the command line. It actually didn’t give me the error 125…instead I simple got the normal message saying whonix check found packages that could be updated.

So I did the manual package update (sudo apt-get update && sudo apt-get dist-upgrade) and it installed a bunch of updates. Then I ran whonix check again and it report all packages were updated (I did not get the error 125).

It appears that doing the manual update has fixed the error 125 issue. I wonder, though, if the error will return the next time whonix check finds packages that need to be updated. I will report back if I get the error again. Thanks for your help.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]