[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix Build (git) - Onionizing clearnet urls

Hi!

I am getting stuck trying to build Whonix, after modifying clearnet urls in the Whonix git sources to .onion ones.

Although I have used the flags --allow-uncommitted true and --allow-untagged true, it seems like some additional steps in git are needed to “commit” the changes, but I am not sure how as I am new to git.

What am I missing?

Thank you

I’ve been referencing: http://www.kkkkkkkkkk63ava6.onion/wiki/Dev/Build_Documentation/13_full

I am getting stuck trying to build Whonix, after modifying clearnet urls in the Whonix git sources to .onion ones.

I don’t know what you did. Whonix git is not available from any onions.

Although I have used the flags --allow-uncommitted true and --allow-untagged true, it seems like some additional steps in git are needed to “commit” the changes, but I am not sure how as I am new to git.

No. --allow-uncommitted true and --allow-untagged true is enough.

What am I missing?

Post enough of the error trace or full log here.

Hi Patrick,

I ran a couple of sed/…/g 's through the sources to change any clearnet URLs to .onion.

For example:
http://deb.whonix.org -> http://deb.kkkkkkkk…onion
http://ftp.us.debian.org -> http://vwakvii…onion

etc…

I’m not sure what I need to do next in order for git to recognize these changes (to “checkout” my modified version)

git tag
git verify-tag 13.0.0.1.4-stable
git verify-commit 13.0.0.1.4-stable^{commit}
git checkout 13.0.0.1.4-stable

I’ve tried these, but do not seem to fix:

git add .
git commit -a
git checkout -b new

I am trying to build Whonix within Whonix, on --arch amd64 (and installed/booted the 64bit kernel), and using apt cacher on the localhost.

Unfortunately my clipboard isnt working right now but will try to get the error logs from the whonix_build if needed.

Thanks

Committing / tagging the changes is really not required. I am using the options to skip these checks all the time during development. Would be way to uncomfortable without.

Probably a syntax error. Make sure you are using the right syntax. Forget about ./whonix_build. That causes too much syntax confusion. Build one VM after another. Example:

sudo REPO_PROXY=http://127.0.0.1:3142 ./help-steps/whonix_build_one --build --allow-uncommitted true --allow-untagged true --arch amd64  --target virtualbox --flavor whonix-gateway

Using onion sources (in combination with an apt cacher) might not work for some reason. It’s not really tested for Whonix 13 builds. Might be supported in Whonix 14.

Thanks Patrick.

I will see if I can get it working, (though doesn’t look too good right now.)

If I ever get it working, will post the sauce :slight_smile:

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]