[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix 15, KVM, High Constant Memory & CPU Usage

I had downloaded the KVM 15.0.0.0.9 file when it was first announced. It was working fine, no issues. A couple of weeks ago, Whonix pushed out a bunch of updates and since then my Workstation VM is using nearly 80% of total allotted memory all the time, and CPU usage is around 30% for a four core intel CPU. In fact, the Workstation starts up very slowly. It will show the Grub screen, and then go black for a few minutes before beginning any kind of startup (it had started up normally before that Whonix update). When I view the Top command on my Debian Stretch host distro, the CPU usage can be as high as 80% with a constant 80% memory usage for the Workstation VM.

When I shutdown the Workstation VM, it shuts down very slowly (minutes) also. The Gateway VM starts up reasonably fine, but after the slow Workstation VM shutdown, the Gateway VM almost freezes. And then it also takes a long time to shutdown.

I have everything updated on my Debian stretch host system, and as well on the Whonix VM’s. I’ve never run into this problem with previous versions of Whonix on KVM. I’m not blaming the Whonix upgrade for the problem, just noticed that since that time is when my VM’s began really bogging down my whole system.

Hi @glass
Did you happen to increase the CPU number allocated to the Whonix VM? If yes, then decreased performance is expected

http://forums.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/t/whonix-15-increasing-allocated-cpu-number-makes-the-vm-incredibly-slow/7335/2

2 Likes

There is this big disclaimer about not changing any settings, so what do I do? Change the CPU and memory settings. I reset them to the XML file specifications and all is well. Thanks for the link. Since this issue is already dealt with in the link onion_knight provided, moderator(s) please feel free to delete this thread.