[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix 14 newest Release KGPG not working


#1

Dear Whonix Team,
First of all lots of respect for the creation of Whonix you guys deserve a donations which i will send to you guys shortly.

I’m using whonix 14 right now and the new designs looks very good and clean. Lots of love for that aswell.

Yesterday i was trying to use the KGPG to create a new key but it gave me an error.
It happened when i was trying to save the .asc file. It says that it was created successfully but it never appears in the selected folder. I know that file is hidden but even so i couldn’t find the key.
Also when i start importing the secret key in to KGPG it gives a error upon importation. When the proces is done the key shows but it doesnt work encrypting/decrypting and even setting up trust level doesn’t work.

KGPG gives no error when i back up the key or generate a keypair but on importing a key it does give a error

[GNUPG:] KEY_CONSIDERED EA75E51FA3481BB155678D3F198D2F76DD3EB618 0
[GNUPG:] IMPORTED 198D2F76DD3EB618 opiumlord
[GNUPG:] IMPORT_OK 1 EA75E51FA3481BB155678D3F198D2F76DD3EB618
[GNUPG:] KEY_CONSIDERED EA75E51FA3481BB155678D3F198D2F76DD3EB618 0
[GNUPG:] IMPORT_RES 1 0 1 0 0 0 0 0 0 1 0 0 0 0 0

The key is not useable after importation.

Then i tried to install GPA which is also a tool to decrypt/encrypt messages. upon generating a key pair it gives this error.
The GPGME library returned an unexpected
error at gpagenkeysimpleop.c:224. The error was:

Inappropriate ioctl for device

This is either an installation problem or a bug in GPA.
GPA will now try to recover from this error.

Can you guys please help me with this!
Thankd in advance


Kpgp Failed to Import key. Whonix 14
#2

Hi whonixisbest

Can you try running your commands in a konsole and post any errors. This will be less buggy than using KGPG or GPA


#3

Hi @,

Same issue here, I can’t import my master key to KGPG on Whonix 14

Capture

Tried to import it in a konsole with

gpg --import private.asc

output

gpg: Total number processed: 1
gpg:               imported: 1
gpg:       secret keys read: 1
gpg:   secret keys imported: 1

But unfortunately, the key doens’t appear in KGPG.

Could somebody please support ?

@whonixisbest : Did you find a solution to solve this issue ?

Thank you !


#4

I was able to solve a part of that issue following these steps :

  1. Import the Master key in a konsole.
  2. Open KGPG, the key won’t appear. (isn’t normal but in that case it is :blush:)
  3. Import the key in KGPG
  4. The Master Key will than appear.

One problem remains, this is not possible to encrypt anything in KGPG even if we have a master key :

Capture

Hope it helps.


#5

This is how I solved this :

  1. Capture

  2. Secondly, go to the menu settings than click on configue KGPG

  3. Capture2

  4. Use your master key ! (Only for encrypting files… :cold_sweat:)

**EDIT : This method only works for encrypting. Decrypting files still gives this message :

Capture

@0brand : are these bugs going to be fixed soon ?


#6

Unknown. But very unlikely to be fixed by Whonix team. Unlikely this bug is caused by anything done by Whonix.

Could you check please as per https://www.whonix.org/wiki/Free_Support_Principle if this bug was reported upstream against Debian kgpg package or against kgpg developers, and if not report the bug?


#7

I am affraid I don’t have the knowledge to do so.

I thought contributing here by reporting bugs would help the Whonix developers and the community… Seems I was wrong.

I got it loud and clear !


#8

Hi Cottonwoodhill

Thats OK :slight_smile:

Reporting bugs is a big help to Whonix. Please understand that Whonix developers have minimal human resources and can only focus on Whonix packages. This means that any non-Whonix bugs must be reported upstream to the respective developers (i.e. Debian, Tor, Qubes etc…etc developers). That way when the bug is fixed, everyone that uses that software package benefits.

All Patrick was doing was trying to point you in the right direction so you could find and answer. Or notify the upstream developers. This could even be a new bug? It would be pretty cool if you found a bug that had not been reported.

P.S. Don’t feel bad. Sometime I get asked to help out with something and I don’t know what the heck I’m doing. :confused:

And thanks for all of your contributions:+1:


#9

Hi 0brand

Thank you for your kind words :kissing_closed_eyes:

As I am new in this unix world, I am not aware of who is doing what and where to go to find some help or report a possible bug regarding the case. I now have understood here should only be reported issues in relation with your distribution and nothing else.

I’ll try to get some support somewhere else. I found https://bugs.kde.org/ KGPG reports

Maybe I’ll knock to the right door that time :cold_face:

Finger crossed :crossed_fingers:

Best regards.


#10

If you are sure it not a Whonix bug. First look for error messages using the forum search engine as well as your normal search engine to see if the bug has been reported already or possibly solved.

I’ll try to get some support somewhere else. I found https://bugs.kde.org/ KGPG reports

Awesome!

If you find a solution please report back :wink:


#11

Installing pinentry-qt on the Whonix workstation fixed the issue for me.


#12

@caavemaan : Fixed my issue too ! Thanks for that :+1: