[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Whonix 13 time sync issue


#1

I just downloaded and installed Whonix 13 for kvm

When Whonix Gateway Whonix check runs I get the following error

PVClock Test Result

Unwanted PVClock kvm-clock acpi_pm detected. Using this PVClock together with Whonix is recommended against because it conflicts with Whonix time sync.

I didn’t get the error on 12 and I’ve changed nothing, I just downloaded 13 and installed it for KVM.

Does anyone know what could cause this? For reference I am using Whonix 12 on my host pc to connect to my dedicated server via SSH which is running Whonix 13 and it is the Whonix on the dedicated server which throwing up the error.

I also uninstalled KVM and Whonix 3 times just to make sure I didn’t install wrong, but it is still throwing up the error, also to note it’s only the gateway, the workstation passes Whonixcheck


#2

@TheLegend2016

Did you download the new images or do an in-place upgrade?

@Patrick please adjust the implemented fix to silence the whonixcheck warning on the gw as per: https://phabricator.whonix.org/T385


#3

I downloaded the new images, however I solved the issue it appears the Gateway.xml has timer name=‘kvmclock’ present=‘yes’ after reading some dev notes on the Whonix main page I saw to change that to no and it worked, it now passes the Whonixcheck.

To note the workstation.xml was already set to no.


#4

For reasons I discussed I saw it safe and convenient to have kvmclock present so the gateway does not have to be rebooted to allow clock syncing even if you suspended your machine for a long time.

The warning is a “bug” and shouldn’t have appeared.


#5

Why hasn’t this been caught during the testing period of Whonix 13?

I considered this done with:
https://phabricator.whonix.org/T385#7722


#6

I guess most people wait for the stable and don’t download the testing because they want a stable release.

Its also my fault because I wait for stable because of long build times.

I considered this done with:
https://phabricator.whonix.org/T385#7722

Me too. I thought it was a simple fix but there must be something else in the whonixcheck code that warns against pvclock.


#7

This is really bad. I was expected, the KVM maintainer, you, to check out testers-only (binary or source) releases for KVM compatibility for both in-place upgrades as well as new builds.

In Non-Qubes-Whonix 13.0.0.1.0 X issues I explicitly asked you for KVM testing for 13.0.0.1.0 because I do not regard KVM compatibility naturally working.

Now we are in a bad state. The downloadable KVM version has a grave usability bug right after download and import that cannot be hidden by an update. (It could be fixed by a stable upgrade that eats up time but would get visible once nonetheless.) Fixing the mess out of the box would require a new build, which is a time consuming process from build, test to release.

Any fix, simple or not should be tested. Looking at the commit https://github.com/Whonix/whonixcheck/commit/88ce7981e57b564aef421aebdbd3e7174c7517c8 again it looks pretty obviously wrong.


#8

Its a mistake and I won’t make excuses for it. I will take care of testing right away next time.

Can an updated whonixcheck package fix this from Whonix repo?


#9

Please test this fix:


It can but users of newly downloaded Whonix 13.0.0.1.1 for KVM will most likely still get this error during first run of whonixcheck because it does not have the fix (before upgrading for the first time). I hope not, but I guess that is how?


#10

So with all the above been said I can modify my .xml and change the setting back to yes and await a bug fix, correct?


#11

I can’t see the error anymore. I guess it has been fixed with the update, am I correct?

EDIT: My bad, sorry. I was running WhonixCheck in WS and it was OK. But when I ran it in the GW the error was still there. Could anyone please share what should I do to correct it.
Thanks
EDIT 2: Should I just go and edit the file as described here:


#12

@Patrick

Confirmed. The changes you made work.

(I’m guessing the changes are not in the 13.0.1.1 developer branch so I went ahead and changed the script to look exactly like your commit and the warning stopped appearing)


#13

These changes are not in any git tag yet indeed.


#14

whonixcheck_3.8.2-1_all.deb was added to stable-proposed-updates just now. Contains the fix. Please enable stable-proposed-updates ( https://www.whonix.org/wiki/Whonix-APT-Repository#stable_proposed_updates ) and test.


#15

Downloaded the latest package from stable-proposed-updates and it doesn’t work, even after rebooting. I get this error:

WARNING: PVClock Test Result:
Unwanted PVClock kvm-clock acpi_pm detected! Using this PVClock together with Whonix is recommended against, because it conflicts with Whonix’s TimeSync design [1].
If you know what you are doing, feel free to disable this check. Create a file /etc/whonix.d/50_whonixcheck_user.conf and add:
whonixcheck_skip_functions+=" pvclock_unwanted_detected "


#16

Please check if the contents of the file in question matches the
previous manual fix.


#17

The new file lacks the fix - its the same as the old one.


#18

My bad. I forgot to actually git cherry-pick the fix. Fixed
whonixcheck_4.6.2-1_all.deb uploaded just now. Please test.


#19

Did an update and it works :slight_smile:


#20

Now in all repos.