[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Whonix 10, 11 developers-only git tags


+

[code]sudo -E ./whonix_build --gnw -- --target virtualbox --build[/code]

Builds fine and works well at first sight.

(https://www.whonix.org/wiki/Dev/Build_Documentation/10_full)

Builds fine and works well at first sight.

(https://www.whonix.org/wiki/Dev/Build_Documentation/10_full)

It builds like a charm (in Whonix) :slight_smile:

The guest additions installation is a plus (for me), one step less for having an usable system.

Fixed an annoying issue (the one shown in the original Whonix Setup Wizard introduction in Whonix blog).
See https://www.whonix.org/forum/index.php/topic,705.msg7443.html#msg7443

Glad to hear!

Will test now…

[font=arial]–tb closed[/font] is another optional simplification. It installs Tor Browser by default in Whonix-Workstation. “closed” means it would fail closed and show and error during build if installation falls. “open” would ignore this and continue. You’d have to check the right version was installed during build. (By checking the build log or by checking the [font=arial]/home/user/.tb/[/font] folder. It’s just an option for custom builds, developers and derivatives. Not for official Whonix redistribute builds (reasons: https://www.whonix.org/wiki/Tor_Browser#Not_installed_by_Default).

If you’re wondering what the “-E” in “sudo -E” is about… I am running “export http_proxy=http://lan-ip:3142” beforehand where apt-cacher-ng is running on a different system to speed up builds.

Will state later if 10.0.0.4.1-developers-only did build.

Works fine on a quick look. Contains the correct version of Tor Browser.

By the way, contains fix for “whonix-setup-wizard repository - code names issue - stable vs wheezy - https://phabricator.whonix.org/T232” and your above fix.

Will test now a jessie based build using tag…

Will state later if that worked.

No. Investigating…

Found the bug.

[bash] exported bash functions broken in chroot
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=780970

Now I need to come up with a workaround.

[quote=“Patrick, post:7, topic:924”]Found the bug.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=780970[/quote]
Also asked on the help-bash mailing list:
https://lists.gnu.org/archive/html/help-bash/2015-03/msg00081.html

“[bash] exported bash functions broken in chroot” has a workaround in:

Whonix-Gateway build finished already and is bootable. Whonix-Workstation build not done yet, but I guess it will work also.

Booted Whonix-Gateway…

whonix-initializer doesn’t work yet. But that is to be expected, since it has not yet been ported to systemd. (https://phabricator.whonix.org/T106)

[code]user@host:~$ sudo service whonix-initializer status
● whonix-initializer.service - Whonix First Run Initializer (text mode)
Loaded: loaded (/lib/systemd/system/whonix-initializer.service; disabled)
Active: inactive (dead)

Mar 25 19:09:18 host systemd[1]: [/lib/systemd/system/whonix-initializer.service:12] Failed to add dependency on sdwdate, ignoring: Invalid argument
Mar 25 19:09:18 host systemd[1]: [/lib/systemd/system/whonix-initializer.service:13] Failed to add dependency on whonixcheck, ignoring: Invalid argument
[/code]

So non-Qubes-Whonix (i.e. VirtualBox, KVM…) users really should manually run for now at first boot as very first thing.

It’s an early test version. Will be fixed.

Anyhow…

It should be a good base to work on systemd:
https://phabricator.whonix.org/maniphest/?statuses=open%2Creview&allProjects=PHID-PROJ-qrbuz4cmegccs5wjhxw5#R

As well as on the Tor systemd startup issue:
https://phabricator.whonix.org/T251

Testing now…

Worked. There is a small issue, that it doesn’t run all non-interactivly.

+ sudo dpkg -i ../genmkfile_1.5-1_all.deb [sudo] password for user:

Will fix that soon. (Easy, looks like.)

Here, it stops on the first step.

main (line number: 632) last_failed_bash_command: $apt_get_update_wrapper_source_path_full $apt_timeout_opts $apt_get_gpgv_opts update last_failed_exit_code: 0 ERROR in ././build-steps.d/1100_prepare-build-machine detected!

Make sure you have Whonix’s repository disabled IF you are building within a Whonix-Workstation. (It clashes with some bug in apt-cacher-ng.) Otherwise please see above what the latest execution and output of apt-get was.

[quote=“Patrick, post:11, topic:924”]Worked. There is a small issue, that it doesn’t run all non-interactivly.

+ sudo dpkg -i ../genmkfile_1.5-1_all.deb [sudo] password for user:

Will fix that soon. (Easy, looks like.)[/quote]
Fixed.
fixed build interactivity issue during build and install of genmkfile:

Might also help to remove ~/whonix_binary folder. (Because of https://phabricator.whonix.org/T246)

Testing now…

10.0.0.4.8-developers-only
sudo -E ./whonix_build --gnw -- --target virtualbox --build --tb closed

Build succeeded.

Testing now…

Build succeeded. Quick test looks all okay. Will likely upload 10.0.0.5.0 as testers-only release.

Build succeeded too.

A couple of issues:

  • genmkfile is not installed (installed it from source).

  • whonixcheck: Debian Package Update Check Result: Could not check for software updates! (apt-get code: 100). apt-get update works from the terminal.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]