[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Weird issue installing on VB with Ubuntu


#1

Hello I recently installed virtual box on ubuntu and downloaded the gateway and workstation. I imported the files to virtual box and both start up fine. However, the two aren’t linked. After I setup the gateway and then started the workstation it gave me an error that the gateway wasn’t running even though it was. When I would try to run anything in the gateway, nothing would work. I couldn’t run whonix check or anything. I tried restarting and had the same problem. What did I do wrong?


#2

Hi David

Sorry to hear you’re having problems. Could you please answer a few questions.

  • did you verify the Whonix images?

  • do you have enough RAM for both your host OS and virtual machines?

    • can you try running just Whonix-Gateway i.e. without Whonix-Workstation (does Gateway work?)
    • you may also need to increase you VM RAM. RAM Adjusted Desktop Starter
  • is Whonix-Workstation functional?

    • if no - could you trying creating a virtual machine with a different iso image. Such as Debian (works OK?)

#3

Hi I did verify the downloads. My host PC has 8GB ram. I’m not sure about the VMs. How do I increase that? All I did was import the ova files…it never gave me an option to adjust ram.


#4

The RAM Adjusted Desktop Starter link in my last post is fixed. Try is now. Sorry about that.

That could be a problem if you can’t open a terminal konsole.


#5

Hello This did not solve the issue after increasing the RAM. Please see attached screenshot. It seems the network between the two aren’t ‘linked’.


#6

Hi David,

That error message is due to Whonix-Gateway not booting correctly. There is no Whonix-Gateway for Whonix-Workstation to link to.

When you first boot the VMs, do you see any error messages such as the ones here:

Also:

  • can you can run commands in Whonix-Workstation Konsole or use desktop apps? Works OK other than not having Whonix-Gateway to connect to?
    – if so, you may want to reinstall Whonix-Gateway. Even thought you verified the image something may have happened to the image afterward (corrupted??) But only after exhausting other possibilities i.e. further troubleshooting

  • is your host Ubuntu updated with the latest packages?

    sudo apt-get update && sudo apt-get upgrade


#7

Thanks. Yes, my Ubuntu is up to date.

To further elaborate, when I start the gateway, everything works fine and there is no error messages. Tor starts fine and when I run the whonix check, I updated everything.

Then I start the workstation and everything starts fine. But then I get that error that its not connecting to the gateway. So I go back to the gateway and when I click on anything its like its frozen. Nothing works.

It seems the work independently, but not together. Im not sure if this is a virtualbox issue or what.
Also, not sure if this would affect it, but Im using libreboot for my bios. Not sure if that would affect anything.


#8

Hi David

Thanks for clarifying. Whonix-Gateway works fine until you start a second VM. I misinterpreted your first post.

This sound like a RAM issue

Are you running a lot of processes on your host OS while using Whonix?

Could you try shutting down anything you don’t need on the host while using Whonix. Does that help?


#9

I’m not running anything else as far as I can tell. I just start the PC and boot up the VM’s. I don’t have any other programs running.

Also, I realized I don’t have guest additions installed. Maybe that could affect it?


#10

No, that if for clipboard sharing, shared folders etc. Would not cause the problems you are having.

How did you install VBox? Did you use:

sudo apt-get install virtualbox linux-headers-$(uname -r)

Did you change any settings in VBox such as the settings for memory? Speaking of that, something else you can try is allocating more memory for VMs in VBox settings.

https://askubuntu.com/questions/510134/how-to-increase-vm-hdd-and-ram-sizes

You may also want use rads again but this time lower RAM to 512 MB in each VM. This is the minimum that is needed for the desktop to start. Any lower and you will get a terminal only Whonix.

I do not believe the problem is with Whonix. These kinds of problems are typically RAM related although it could be something to do with VBox or even the host.