Waydroid download

I know that there are a lot of topics about it, however i haven’t found this problem solved. (I swear i really tried)

I need to download Waydroid on Whonix - Virtualbox and when i execute
curl https://repo.waydro.id | sudo bash
following the tutorial by waydroid or adding repo as I have seen in another topic on this forum with following command:

export DISTRO="bullseye" && \
sudo scurl -Sf https://repo.waydro.id/waydroid.gpg --output /usr/share/keyrings/waydroid.gpg && \
echo "deb [signed-by=/usr/share/keyrings/waydroid.gpg] tor+https://repo.waydro.id/ $DISTRO main" > ~/waydroid.list && \
sudo mv ~/waydroid.list /etc/apt/sources.list.d/waydroid.list && \
sudo apt update

I get this error:

[sudo] password for user:           
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  1754  100  1754    0     0    776      0  0:00:02  0:00:02 --:--:--   776
Hit:1 tor+https://deb.debian.org/debian bookworm InRelease                     
Hit:2 tor+https://deb.whonix.org bookworm InRelease                            
Hit:3 tor+https://deb.debian.org/debian bookworm-updates InRelease             
Hit:4 tor+https://deb.debian.org/debian-security bookworm-security InRelease   
Hit:5 tor+https://deb.kicksecure.com bookworm InRelease                        
Get:6 tor+https://fasttrack.debian.net/debian bookworm-fasttrack InRelease [12.9 kB]
Hit:7 tor+https://deb.debian.org/debian bookworm-backports InRelease           
Get:8 tor+https://repo.waydro.id bullseye InRelease [1312 B]                   
Err:8 tor+https://repo.waydro.id bullseye InRelease                            
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E406D181DCEE19C
Reading package lists... Done                                                  
W: GPG error: tor+https://repo.waydro.id bullseye InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E406D181DCEE19C
E: The repository 'tor+https://repo.waydro.id bullseye InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
zsh: exit 100   sudo apt update

I’m not really experienced in Linux so maybe you’ll find this question stupid. But I still need your help. Thank you

That is solvable.

Next issue you’ll have you’ll also need Wayland not X11.

1 Like

Example setup for Qubes OS but it’ll work for Whonix in Virtualbox as well:


Thank you for your answers. But i have another problem. Key fingerprints don’t match:


pub   rsa3072/0E406D181DCEE19C 2023-08-03 [SC] [expires: 2099-08-03]
      Key fingerprint = 7CE0 331F 71E0 A238 BB10  02D7 0E40 6D18 1DCE E19C
uid                            Czarek Nakamoto <ci@mrcyjanek.net>
sub   rsa3072/2BF5573548220A06 2023-08-03 [E] [expires: 2099-08-03]

Provided by kicksecure:

0D27 43A2 4328 AE06 34DF 3557 959F E34E 90E5 1522

What should I do?

1 Like

Did you study Verifying Software Signatures - Kicksecure yet? Required for verification to be beneficial.

1 Like

The old key has expired and Waydroid developer created a new one but didn’t upload it anywhere else.
The issue with keys handling seems to have a low priority for the Waydroid developer:

For reference, the new key fingerprint downloaded by me from https://repo.waydro.id/waydroid.gpg matches the one you’ve posted.

1 Like