[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Want a local backup of Whonix wiki contents? / Replicating whonix.org wiki

website

#1

Originally published at: https://www.whonix.org/blog/whonix-wiki-backup
Public for a long time, yet seemingly not found by anyone.

mediawiki markup:
https://github.com/Whonix/whonix-wiki-backup

mediawiki xml:
https://github.com/WhonixBOT/WhonixWikiBackups

git clone
it. Fork it on github. Ideally keep it current.

Test our instructions for replicating whonix.org.
https://www.whonix.org/wiki/Dev/Replicating_whonix.org

Help creating a Whonix backup script:
https://phabricator.whonix.org/T159

We are also currently trying to figure out offline documentation.
https://forums.whonix.org/t/offline-documentation-discussion

A lot to do. A lot opportunities to contribute.
https://www.whonix.org/wiki/Contribute


New Qubes Website! New Whonix Website?
Subscribing to Wiki / Documentation Updates
#2

Good day,

sorry to say, but I just tried the guide at: https://www.whonix.org/wiki/Dev/Replicating_whonix.org When I get to the point where I should be able to visit: http://127.0.0.1/wiki/mw-config/index.php to setup the wiki, though, I get the following: “The requested URL /wiki/mw-config/index.php was not found on this server.”

What am I doing wrong?

Have a nice day,

Ego


#3

Good question. Next question.

Seriously, the guide may require a revision. Using a newer mediawiki
version. Then comparing with the usual mediawiki installation and backup
restoration instructions.


#4

Working on this now to unblock @Ego working on:


I was not able to create a simple /var/www/index.html either. Seems like Debian now set the default apache www folder to /var/www/html. So instead of using /var/www as the broken guide suggests, please try using /var/www/html.

I am not sure yet how to update the instructions. Either changing the apache setting to point to /var/www instead so it would be closer to our whonix.org server setup or to change the instructions to /var/www/html so we don’t have to edit another file.


#5

Good day,

Great, will try this, once I’m at home.

Have a nice day

Ego


#6

Good day,

tried it now multiple times. By using /var/www/html instead of just /var/www, I’m able to get up to the step, where I’m supposed to run “sudo -u www-data php /var/www/html/wiki/maintenance/update.php --quick”. However, when doing that, I receive the following warning:

PHP Warning:  require_once(/var/www/html/w/extensions/Widgets/Widgets.php): failed to open stream: No such file or directory in /var/www/html/w/LocalSettings.php on line 409
PHP Fatal error:  require_once(): Failed opening required '/var/www/html/w/extensions/Widgets/Widgets.php' (include_path='/var/www/html/w/extensions/OpenID:.:/usr/share/php:/usr/share/pear') in /var/www/html/w/LocalSettings.php on line 409

Do you have any idea where the problem may lie?

Have a nice day,

Ego


#7

Because you did not have that file yet. Was a server side git backup
issue. I updated that git repository. Please fetch/merge [or clone a
fresh copy].


#8

Good day,

ok, I’ll try that once more. Having a local copy to experiment with will definetly be benifical, for the simple reason of beeing able to try out new styles, etc.

Have a nice day,

Ego


#9

Any updates?


#10

Good day,

Sadly not. On nothing for that matter. I am currently a bit occupied by a few rather important tests I have to focus on. Regarding the backup, if I recall correctly, I sufferd under the same error again. I didn’t want to ask a fourth time then, as this seems to be both, a problem not necessarily easy to fix, but also not so severe that I could justify wasting to much of your time on it, as like said before, I currently have little time to really find a reason behind the behaviour.

Luckily, soon the “testing season” is behind me, so I may look into this, as well as a few other projects, again with the necessary focus.

Have a nice day,

Ego


#11

Keep your time with private matters. Don’t worry about my time, since I
find this worthwhile, i.e. getting you started with this.