[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

{virutalbox} Whonix release upgrade failure - networking broken

I followed these instructions exactly on my gateway, it finished with an error, sorry i cant post it verbatim because i cant copy it to my workstation and i cant post from the gateway, it said “error processing package grub-pc”. I rebooted and the the padlock sync icon in the upper right no longer appears and workstation wont connect to internet. I tried sudo apt-get update and sudo apt-get upgrade and it gives this huge list over 200 items of things, i select to upgrade, it finishes with same grub error. I reboot, no tor still, i try upgrade again, same huge list of things, same error. I copied over from my backup since this release is broken and i dont want to try it on my workstation.

EDIT: There were a couple things i might have answered wrong, during the update process it asks if i want to keep the same keymap, i selected yes, then later it asked if i want to keep the sources i have or the updated one from the maintainer, i selected to keep the same ones, i dont know what this means and it was never written in the instructions how to answer this.

Blockquote

Release Upgrade

  • Backup all data - ideally have a clone of the VM(s) so it is possible to try again (if necessary).
  • Perform the usual [standard (“everyday”) update instructions]
  • Consider running the optional [sanity tests]
  • Run [systemcheck]
  • View release-upgrade command version.

cat /usr/sbin/release-upgrade | grep version=

  • Check release-upgrade command version. Should be minimum 1.5, should show version="1.5".
  • Consider keeping the full release upgrade log output. It will be required for [Support] in case there are issues.
  • Perform the automated [release upgrade using release-upgrade command.

sudo release-upgrade

  • Done. If everything went well, at the end it will show:

INFO: OK. (release-upgrade version: 1.5) Release upgrade success.

  • Reboot.

Seems pretty difficult to fix. There’s a chance but doesn’t seem big.

Whonix ™ Factory Reset, Re-install method would probably be much easier.

Yes.

Needed indeed.

I cant factory reset my workstation, and i dont know where any upgrade log output is or how i would post it from the gateway without breaking all sorts of security

Please open a separate forum thread to resolve that.

It is the terminal output shown during release-upgrade. If you didn’t store it and closed the window already then it’s gone now.

If you don’t have a clone or snapshot chances to receive free help to repair it are minimal. Fixing a broken APT state is hard, even harder once Tor connectivity is broken. Hard means needing a lot time, meaning expensive.

Clipboard Sharing

I retried the upgrade process with a backup and it worked now, maybe something changed? It didnt ask me any questions about changing my keyboard or source lists this time. Thanks for the help.

No.

release-upgrade internally uses apt-get-noninteractive. If you’re using apt / apt-get manually- then it’s interactive and asking complicated questions.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]