[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

VirtualBox - Whonix and Windows XP

Hello everybody :slight_smile:
In the begining, please forgive me my english, I’m foreigner.

I’m trying to make something like that:

General computer with the cable clearnet --> VirtualBox 4.3.12
In the VirtualBox:

  1. Whonix Gate-way 8.2
  2. Windows XP SP3 OEM

For this moment it’s all OK, Whonix has all updates (2 days ago) and Windows also has all updates.
When I started Whonix, whonix-check said " Connected to TOR" and timesync is also OK.

Ok, let’s go to Windows. I set up properies:
IP address 192.168.0.50
Subnet netmask 255.255.255.0
Default gateway 192.168.0.10
Preferred DNS server 192.168.0.10

Save and after that " Network connected",but I don’t have internet on this OS…

Ok,come back to Whonix.
I turned on “Tor controller” and set Relaybandwithtset and RelaybandwithBurst to 1 GB and after that I see a move in download/upload. But still no internet in Win XP.

There are a few screen:





Please,help me…

Hi!

Don’t use bridged networking (https://www.whonix.org/wiki/Security_Guide#Warning:_Bridged_Networking). Leave the defaults for Whonix-Gateway adapter 1 (NAT).

I turned on "Tor controller" and set Relaybandwithtset and RelaybandwithBurst to 1 GB and after that I see a move in download/upload.
This has nothing to do with using Tor as a client.

If Tor doesn’t connect, try restarting Tor or Whonix-Gateway.

Does a default Whonix-Workstation work for you?

In case you want to use multiple workstations at the same time, see:

Hi :slight_smile:
Thanks, now first Whonix adapter is NAT,and TOR it’s OK.

This has nothing to do with using Tor as a client.
Ok,in this case, I make restart and now it,s all default.
Does a default Whonix-Workstation work for you?
I don't have Whonix-workstation, only Gateway. Should I install Whonix-workstation?

Ok, I was installing Whonix-Workstation 8.2 . Download all updates, Tor Browser and all is OK. I can go to .onion sites and in to the check.torproject.org said “you use tor”.
But still I don’t have intenet on to Windows XP…
Any sugestions?

Are you starting and using Whonix-Default-Workstation and Whonix-XP-Workstation at the same time? Won’t work, unless you give them unique IPs as per https://www.whonix.org/wiki/Multiple_Whonix-Workstations.

Did you follow instructions from https://www.whonix.org/wiki/Other_Operating_Systems#Windows-Whonix-Workstation step by step?

Did you follow instructions from https://www.whonix.org/wiki/Other_Operating_Systems#Windows-Whonix-Workstation step by step?
No... I forgot "VM settings"... I was delete Whonix-Gateway and make all again. I was doing all with the instructions, and now is worse. VM settings into vboxmanage, I was doing only for Whonix-gateway. "Bootstrapping 80% done " And if I do wchonixcheck again,its this same,80% [img]http://zapodaj.net/images/4f80bb48dd2d3.jpg[/img]

Now I don’t have internet in Whonix-workstation and also Windows XP…
What do I wrong?

For Whonix-Gateway, you don’t have to change any settings in VirtualBox by the way.

What about recommendation 1)?

Does the Tor Browser Bundle by The Tor Project on your host work for you?
(https://www.whonix.org/wiki/Pre_Install_Advice#Tor_Browser_Bundle)

For Whonix-Gateway, you don't have to change any settings in VirtualBox by the way.
I did again anew,beacuse I don't know how reverse VM Settings. Of course I did all, without VM Settings.
Does the Tor Browser Bundle by The Tor Project on your host work for you?
Yes, I have installed Tor Browser Bundle into my general OS,Win 7, and I can go to .onion sites.

Ok, now it’s better. In Whonix-Gateway is all OK, in Whonix-Workstation is the tor internet. But still doesn’t in to the XP.

I’m reading now: https://www.whonix.org/wiki/Multiple_Whonix-Workstations#How_to_use_more_than_one_Whonix-Workstation_-_EASY
I stuck on “(3). And change the last octet. E.g” I have there a few IP’s and I don’t know whichone must I edit. I have 2 different MAC address for Whonix-Gateway and Windows XP.

That’s my /etc/network/interfaces :

When I changed “address 192.168.0.12” to “address 192.168.0.50” and restart, I still have offline XP…
That’s my /etc/resolv.conf :

And that’s my XP configurations :

What I did wrong now :frowning: ?

Why did you change any settings in Whonix-Gateway? Maybe documentation was too ambiguous here. That’s the mistake. By editing Whonix-Gateway, you broke it’s internet. Either undo the changes or import a fresh one. You’re not supposed to edit Whonix-Gateway’s /etc/network/interfaces.

The https://www.whonix.org/wiki/Multiple_Whonix-Workstations#How_to_use_more_than_one_Whonix-Workstation_-EASY page has been edited by me to make it less ambiguous, so it’s clearer where settings have to be changed. But you don’t need that https://www.whonix.org/wiki/Multiple_Whonix-Workstations#How_to_use_more_than_one_Whonix-Workstation-_EASY at all for this use case. Whonix-Default/Download-Workstations come with IP 192.168.0.11 by default and the https://www.whonix.org/wiki/Other_Operating_Systems#Windows-Whonix-Workstation chapter currently recommends 192.168.0.50. There should not be a conflict.

In summary, keep Whonix-Gateway’s settings unchanged for this use case. Only change VM settings and network settings for the Windows-Workstation as suggested under https://www.whonix.org/wiki/Other_Operating_Systems#Easy.

Yess! :slight_smile: Windows XP works ! :slight_smile:
All of my problem was VM Settings for Windows workstation :slight_smile:

Thank You very much!

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]