[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

VirtualBox Kernel not installed and fixes won't work. Can't start Whonix

I’ve been trying to get Whonix to work for the past couple days and have been running into every issue possible. I finally got all my machines imported into VirtualBox but now I can’t start any of them. When trying to start a machine I get the following error message:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall virtualbox-dkms package and load the kernel module by executing

‘modprobe vboxdrv’

as root.

where: suplibOsInit what: 3 VERR_VM_DRIVER_NOT_INSTALLED (-1908) - The support driver is not installed. On linux, open returned ENOENT.

After following directions and entering the above command I receive the message:

 modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.15.0-23-generic

Looking through previous questions I ran across the suggestion of reinstalling dkms however I run into another roadblock there too:

Smith@laptop:~$ sudo apt-get install dkms
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.

Smith@laptop:~$ sudo dpkg --configure -a
Setting up virtualbox-dkms (5.2.10-dfsg-6) …
Removing old virtualbox-5.2.10 DKMS files…

-------- Uninstall Beginning --------
Module: virtualbox
Version: 5.2.10
Kernel: 4.15.0-23-generic (x86_64)

Status: This module version was INACTIVE for this kernel.
depmod…

DKMS: uninstall completed.


Deleting module version: 5.2.10
completely from the DKMS tree.

Done.
Loading new virtualbox-5.2.10 DKMS files…
Building for 4.15.0-23-generic
Building initial module for 4.15.0-23-generic

At this point my terminal just gets stuck and will not finish the command. What should I do?

What host OS and which version are you using? Looks like something debian based but with maybe a custom kernel? There are usually some custom config options depending on the hypervisor. Though, I am not sure if there is something related VirtualBox. Did you actually try to reinstall “virtualbox-dkms” ? Just the “dkms” package might not help you. iirc rebuilding the module also takes a while sometimes.

1 Like

I’m on Ubuntu and how long can rebuilding the module take? I’ve tried it many times and let it go for minutes before I stopped it but I havent left it running for any absurd amount of time yet

Sometimes it can take more than a few minutes depending on your hardware. Not an insane amount if time though.

I agree with Algernon about reinstalling virtualbox-dkms.

sudo apt-get --reinstall install virtualbox-dkms

1 Like

VirtualBox installation issues are not Whonix issues and can be sorted out as well as per https://www.whonix.org/wiki/Free_Support_Principle.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]