[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Virtualbox guest additions uninstalled - no more KDE desktop

So I uninstalled the virrualbox guest additions via
sudo purge virtualbox-guest-*
and rebooted.
Now it will no longer boot into KDE. If I reinstall virtualbox-guest-x11 it will again boot into KDE.
So I end up the the command prompt telling me to enter username/password.

How can I boot into the GUI without the guest additions?

Thanks

EDIT: HowToFix:
sudo apt-get install xserver-xorg-video-fbdev
reboot.

No idea?
I thought guest additions were added later to Whonix and were not in the first releases.
How did it work before?

I don’t know the answer.

I would search “debian auto-start kde”

It really should not happen. Perhaps you mistyped. And/or uninstalled a few other packages. Starting with a functional Whonix-Workstation and posting the log of removal might help.

See also:
https://www.whonix.org/wiki/VirtualBox_Guest_Additions#Installed_by_Default

New installation.
whonix stable repository
whonixcheck ran through
apt-get update
apt-get purge virtualbox-guest-x11

http://postimg.org/image/i1h8n6193/

Problem as described above.

Virtualbox 5.0.6, W7x64

EDIT:
While at it; “Temporary disable Guest Additions” from https://www.whonix.org/wiki/VirtualBox_Guest_Additions#Installed_by_Default will also not work, as they will keep on getting loaded.
What you can do, is use fake install by making (for example) a vboxvideo.conf with install vboxvideo /bin/true. More here: https://wiki.debian.org/KernelModuleBlacklisting

And after reboot, there will be no more desktop environment?

Correct.
http://postimg.org/image/nrextwmv5/

(I also added an edit above, don’t know if you saw it).

It should not matter, but for completeness sake, you may want to purge
the following packages.

virtualbox-guest-utils

virtualbox-guest-dkms

And then run autoremove.

sudo apt-get autoremove

Consider sharing the logs.

However, it’s a strange issue. Should not happen. (Above likely won’t
resolve your issue.)

Try starting kdm login manager manually.

sudo service kdm start

Check syslog, kern log, and especially X logs.

Try using non-Whonix, Debian jessie with KDE without guest additions
installed. See if that works. Quite possibly this is not a Whonix, but
general Debian / X / VirtualBox issue.

A wild guess is, that due to some hardware issue, you are able to use X
when having guest additions graphic driver installed but not with
default driver.

“sudo service kdm start” does nothing at all, not even giving any message (beside password of course if not logged in as root).

I will try “debian-8.3.0-i386-kde-CD-1.iso” from http://cdimage.debian.org/debian-cd/8.3.0/i386/iso-cd/

/var/log/Xorg.0.log:
http://postimg.org/image/f13h5r3el/

Does the X log go on and have any EE lines?

This is the complete log (minus one empty line).
EDIT: Just in case you overlooked it, there are two screenshots in this one image.

Thanks. I overlooked this indeed. Sorry.

Uninstallation of virtualbox-guest-x11 might not be complete (as it still tries to load vboxvideo).

The required xserver-xorg-video-* package (whichever that is) is not installed.

As a quick and dirty test, see if installing the xserver-xorg-video-all package fixes autostart of kdm after reboot.

xserver-xorg-video-vesa alone might be enough. If it’s that one, if there would be faster alternative one.

Please test and leave feedback.

Installed
xserver-xorg-video-fbdev
and
xserver-xorg-video-vesa

Now it works.

1 Like

Does it also work with just either one?

fbdev is enough (according to the log it seems to get selected first anyway).
According to some statement I found:

fbdev is the: “frame buffer device”. It is a bit more enhanced than vesa, taking advantage of 2D hardware acceleration such as scaling if available.

So I guess it’s ‘better’ and therefore tested before vesa fallback is used.

1 Like

Perhaps these packages should be installed by default in Non-Qubes-Whonix anyhow then. Just in case upgrading guest additions [or whole Debian] one day goes wrong [in corner cases] it’s better to have a desktop environment at all as opposed to none.

1 Like

I would agree.
Whereas maybe not the -all package(?). As more packages/drivers might lead to more security risks(?). Only vesa/fbdev as the lowest fallback.
Thanks for the tip with Xorg log, after that the problem/cause became apparent.

The -all would be a waste of space but probably no security issue since these drivers would not be load.

EDIT: Just found out, that you had a wiki page about screen resolution without guest additions. Will test this later. (The last part of my post about disabling the kernelmode drivers is still valid though).


Used whonix again today and I found a little problem with the solution of removing all virtualbox-guest-* packages.
When not using the vboxvideo driver you only get 1024x768 as an option. I tried adding new modes to xrandr (800x600 for testing):

cvt 800 600 60
xrandr --newmode <Modeline> (replaced with the real one of course)
xrandr --addmode default 800x600_60.00
xrandr --output default --mode 800x600_60.00

But it failed or nothing happened at all.

So I reverted back to installing guest additions but disabling it via the way described here:
Post above.
If you do it like explained on the whonix wiki it will not work and lsmod will still show the drivers being loaded.
At least I hope the drivers are not loaded that way, but I would prefer not having them at all. But if anyone gains root to enable them again this person could also use root to just install them anyway and use a potential exploit for them, so I guess it’s ok that way.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]