[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

VirtualBox 6.1 + Whonix 15 = Aborted

Hello everyone! I have been using Whonix 14 for a long time and everything have been working fine but unfortunately I need some soft as libreoffice which I can’t download there because Whonix 14 isn’t supported. I had to upgrade it. I should note that I used VirtualBox 5.3 with Whonix 14. I decided to make new one from scratch. Downloaded Whonix 15 and import it. I faced with the problem that clipboard didn’t work. I decided download new version of VirtulBox = 6.1 This is solved the problem with clipboard but I faced with the bigger problem instead . Now after some time (different time ) VM just close without any reason and in main window of virtulbox I see the title “Aborted” . I have several VMs (Whonix 15, Whonix 15, Whonix 14) which usually work together (multiply workstation) and what is strange that one of them work normal (whonix 15) but the other two often crash together in one time. The difference between two whonix 15 is that in one installed psi+ v0.16 . I paid attention to version on psi+ special because it’s the version for jessie, some plugins in it work better than in new one. Maybe is that the reason? One more thing I want to note is that I am not cloned first Workstation 15 when I made second Workstation 15 , I just imported all machines again from OVA and then delete second gateway which I didn’t need , leaving the second workstation 15.

Info about host

System:    Host: user Kernel: 4.15.0-91-generic x86_64 bits: 64 gcc: 7.4.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu4) dm: lightdm Distro: Linux Mint 19 Tara
CPU:       Quad core Intel Core i7-8550U (-MT-MCP-) arch: Kaby Lake rev.10 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15936
           clock speeds: min/max: 400/4000 MHz 1: 1900 MHz 2: 1900 MHz 3: 1900 MHz 4: 1900 MHz
           5: 1900 MHz 6: 1900 MHz 7: 1900 MHz 8: 1900 MHz
Graphics:  Card-1: Intel UHD Graphics 620 bus-ID: 00:02.0 chip-ID: 8086:5917
           Card-2: NVIDIA GP108M [GeForce MX150] bus-ID: 01:00.0 chip-ID: 10de:1d12
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.05hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
           version: 4.5 Mesa 19.2.8 (compat-v: 3.0) Direct Render: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:9d71
           Sound: Advanced Linux Sound Architecture v: k4.15.0-91-generic
Partition: ID-1: / size: 901G used: 452G (53%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 705M used: 368M (57%) fs: ext4 dev: /dev/nvme0n1p2
           ID-3: swap-1 size: 17.02GB used: 0.70GB (4%) fs: swap dev: /dev/dm-3

I don’t understand how can I attach the log file from VB here?

Welcome back!

No VM should be capable for crashing the VirtualBox host software. That is a VirtualBox host software bug which is not developed by and cannot be fixed by Whonix. This bug can be reported against VirtualBox upstream.

VirtualBox has various issues.

The internet is full of discussions that lead to no solution. Hard to find good information. It is unhelpful to ask in arbitrary places about it as this only leads to more discussions which go nowhere. The only option is to find out what information VirtualBox developers are asking for, to write a good bug report and to report to virtualbox.org developers.

For inspiration on how to write a good bug report, see:
https://www.whonix.org/wiki/Dev/VirtualBox#VirtualBox_Bug_Reports

I guess in your case at minimum the VirtualBox VM log and maybe the VirtualBox host log would be useful. Please also mention VirtualBox host version, host operating system and version.

darkrole;
Virtualbox will ask you for the machine log, and a bug report that you can file on their site. Know in advance, that you will need to create an identity on their forum, and register a username. Also, Tor has not worked well for me, maybe they block exits, I do not know.
I also have Virtualbox on one of my machines, version 6.1.4 and the latest Whonix 15 which is using guest additions from the same branch. I have not had this happen to me as far as the abort issue.
Some brainstorming about the problem:
Are you using 3d acceleration? Sometimes, there are certain issues that can cause malfunctions when this option is enabled. Also, did you try the different graphics adaptors? Reason I ask, is that I have found that the vmsvga without the 3d acceleeration works very well (a small error on stdin regarding log mesages notwithstanding, harmless though) with later model intel systems. I do not know if you are using your Nvidia card as your graphics controller; sometimes there are issues with different graphics vendors. Integrated intel hd or uhd works well. Give you video memory the full 128mb in the virtualbox manager gui. Do not use any of the 3d or 2d options. If you cannot solve the issue with vmsvga, try the “VBoxSvga” option as a fallback. Then as lastresort, try the “VBoxVGA” option.
Do you see any messages before the machine aborts? (journalctl) Sometimes upcoming issues are hinted at in the boot logs.
Is your Ram enough? both the host and the virtual machines? I had an issue a while back and it turned out that the gateway needed more ram. If your system can handle it, try giving the gateway at least 1200 mb and the workstation 2048 mb if you have not already.

Ths a lot for your answers.

No

I give it a try following yours recomendation.

No. It’s doing silently.

I’ve checked it but unfortunately I can’t understand this log. I can download it here if you tell me how (I can’t find how to attach log files here).

You can paste the log here. Surround it by code tags.

```
log paste here
```

Or paste on any paste website such as https://paste.debian.net.

I made the topic as you advised on vitrualbox.org . Is it ok I just attached a link on log files from there?

https://forums.virtualbox.org/download/file.php?id=38142
https://forums.virtualbox.org/download/file.php?id=38138

What’s the link to the virtualbox forum post?

https://forums.virtualbox.org/viewtopic.php?f=7&t=97436&p=472675#p472675

1 Like

Was that log recorded in a moment of an actual crash? Should be.

If you previously used Whonix-Workstation without crash, then shut down, then upload log, then that log won’t show any error. VirtualBox also keeps old logs in the same folder.

That’s the strange it’s actual log file exactly after crash. I made new themes I think it’s directly connecting with this problems too - Kernel v.14.19.0.8 and distribute whonix 15.0.0.9.4

Okay, I reviewed your journal and the Vbox log. A couple items of interest caught my attention.
I noticed that the “dvd” blank sata disk in the workstation is no longer present. There is a raw disk pointing to a guest additions iso image in /usr/share. You do not need a separate Guest Additions iso.
In the journalctl log from the Workstation, I found a line with a VBoxClient segfault. LightDm is having a problem loading something. You mentioned a theme you added. Could it be possible to remove it, remove the unnecessary guest additions iso. Also please add a blank “dvd” underneath the main .vdi in “Storage” on the Virtualbox gui, remove the iso and its disk and see if that helped fix it?

EDIT
On further examination of the journalctl log file, it became clear that there is nothing wrong with lightdm loading as I had thought. I reached this conclusion because my Workstation has the exact same log message and mine works fine. Please disregard.
For reference, I tested in Virtualbox 6.1.4 on an Ubuntu host, on Whonix 15 (fully up to date).

1 Like

Good points!

  • Don’t mix repositories. Whonix 15 is based on buster. My mixing with older repositories certainly things can go wrong.

Please compare with your local installation. Might include the same output. If not, please quote here.

wrote another reply here just now:

https://www.virtualbox.org/ticket/19429#comment:3

@Patrick
You are correct; my Workstation contains the exact same (harmless) log message. I edited my previous reply for reference.

1 Like

Hello! Ths for your help. I’ve added reply in that topic (https://www.virtualbox.org/ticket/19429#comment:3)

Thank you for your efforts! Did the VM abort? Did the VM show guru mediation? Gateway or Workstation or both?

Yes. Workstation has aborted.

May be I don’t understand exactly what does it mean but No. Workstation just show aborted without any more error.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]