[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Using Remmina Issue

So ive read and Read and READ & cant find a solution to this. Im trying to connect to an RDP from indide whonix via Remmina…

I can connect easily to my office Desktop…(Business Server 2011)

But im unable to connect to this Server 2008 R2 Desktop… I keep getting this error:

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.
loading channel cliprdr
connected to 72.48.229.162:3389
Could not open SAM file!
Could not open SAM file!
SSL_read: Failure in SSL library (protocol error?)
SSL_read: error:14094419:SSL routines:SSL3_READ_BYTES:tlsv1 alert access denied
credssp_recv() error: -1
Authentication failure, check credentials.
If credentials are valid, the NTLMSSP implementation may be to blame.
Error: protocol security negotiation or connection failure
Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.


Im stumped

Good day,

sorry to tell you, but this doesn’t seem to be a problem created by Whonix, seeing how one RD can be accessed, while the other one can’t, which is why it will be hard to help you on that.

Regarding the error you got, maybe this can help you: https://github.com/FreeRDP/FreeRDP/issues/733

Have a nice day,

Ego

Learning to really use linux is very hard for me. I dont even know how to change any of the things those guys are mentioning in that thread.

Sounds like neither a Linux issue nor a Whonix issue. Remmina has tested fine for me in Whonix.

You need support for Remmina, FreeRDP, or Windows.
Try connecting from a Windows machine.
Or try a different OS in your VPS.
Or try a different protocol like VNC.

Connecting to a RD from within Whonix is a very special use case - unlikely to find much help here.

Isnt FreeRDP seperate from Remmina? In there another platform that can be installed via apt-get that I can use other than Remmina? I tried installing VB inside Whonix and running a Windows 7 VM, but I cant seem to get an internet connection inside of it so that led to nothing. Ive had Whonix for quiet sometime but I rarely use it so im very limited to what I know about it. Im trying to get more into each day though. I Like the comfort of security and using an OS that not many use.

So I installed Rdesktop but I guess its all command line. I need to be able to see the desktop.

For someone who admits to knowing little about Linux or Whonix, you sure are into some voodoo magic. Nested VMs? Tunneling Remote Desktops through Tor? If you’re worried about getting hacked again, Whonix as-is will serve you just fine.

That’s called Security by Obscurity and it’s not a good thing:
Security through obscurity (wiki)
The three approaches to computer security (technical)
Thankfully, Whonix is Based on Debian and many people use Debian.

lol well, after we last spoke I read all the places you guys pointed me to se I learned how to install VB inside Whonix and import an image. But I was unsuccessful in connecting a Internet connection to it, plus yall said that it wasnt smart.

The link you just sent. I read and nearly all of it was foreign to me. But I could learn. & I will eventually.

I was fine with the idea of just using Remmina inside of Whonix. But this is presenting me a problem.

I installed Rdesktop and tried to connect and got this error:

ERROR: CredSSP: Initialize failed, do you have correct kerberos tgt initialized ?
Failed to connect, CredSSP required by server.

I don’t recall you ever mentioning nested vms prior to now. Must’ve been someplace else.

I would never say it wasn’t smart if you had a reason to do it.
That’s the whole issue here. You won’t give even the most general motivation for all of these maneuvers - which makes it difficult for anybody to give you any advice at all.

As for Remmina & Rdesktop, you might get lucky and find someone here who has experience with those products but chances are you’ll do better by visiting those product forums.

/peace

Ive been working from home more lately due to certain personal reasons so I need to be able to access office desktops from home. Im sure im overly paranoid now due to the fact that my system was compromised in the past which is why im operating from inside whonix now. Originally I was just accessing work desktops from windows rdp. Now im just trying to go through whonix. Its just more difficult than I planned. Ill see what I can figure out with the info you have provided though.

That’s not paranoia. That just doesn’t make any sense. Your connection to your work computer will be encrypted already. Are you trying to connect anonymously? Won’t you be logging in with your own credentials? Are you trying to hide the fact that you connect to your work computer from your ISP? I don’t think much investigation is required to figure out that the person logging into your work computer is you - whether you use vpn+tor or not. Plus, your network admin who is definitely paranoid now might be whitelisting incoming IPs and won’t be too thrilled with connections coming from Uzbekistan.

That’s fine. Set up a separate machine or use a virtual machine. Don’t use an Admin account. Set up a strict firewall. Be disciplined and only use it to connect to work - even using Whonix or Qubes, you need to compartmentalize your activities. For more security, use Ubuntu (friendly enough for new linux users). Or use Workstation without the Gateway. But you’re really just defending against your own bad habits. Then setup Whonix for everything else - email, browsing, etc. For dangerous activity, revert your snapshots, or use another VM entirely.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]