[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Unable to update packages from the Whonix repository

When I run upgrade-nonroot, all Debian packages from deb.debian.org are updated properly, and all Whonix packages from deb.whonix.org return a 404 error:

(...)
Err:17 tor+https://deb.whonix.org buster/main amd64 systemcheck all 3:21.6.2-1
  404  Not Found [IP: 127.0.0.1 9050]
Err:18 tor+https://deb.whonix.org buster/main amd64 whonix-shared-packages-recommended-cli all 3:21.5-1
  404  Not Found [IP: 127.0.0.1 9050]
Err:19 tor+https://deb.whonix.org buster/main amd64 whonix-workstation-packages-dependencies-pre all 3:21.5-1
  404  Not Found [IP: 127.0.0.1 9050]
(...)

Updates used to work perfectly, and to the best of my knowledge, broke without any changes on my part.

Everything else works as expected.

Is there something I need to update in my configuration?

Gateway? workstation? kickstarter? 16.0.3.7-stable ?

Gateway and Workstation. I’m unsure what the version number mentioned refers to.

systemcheck displays this warning, telling me to run upgrade-nonroot, which is what I have the problem with in the first place:

WARNING: Debian Package Update Check Result: Could not check for software updates! (apt-get code: 100) 
Please manually check: 
(Open a terminal, Start Menu -> System -> Terminal.) 
upgrade-nonroot

Running apt-get dist-upgrade results in the same 404 errors.

Running apt-get update returns this error:

user@host:~$ sudo apt-get update
Hit:1 tor+https://deb.debian.org/debian-security buster/updates InRelease
Hit:2 tor+https://deb.debian.org/debian buster-updates InRelease
Hit:3 tor+https://deb.whonix.org buster InRelease
Hit:4 tor+https://deb.debian.org/debian buster InRelease
Reading package lists... Done
E: Release file for tor+https://deb.whonix.org/dists/buster/InRelease is expired (invalid since 16h 46min 46s). Updates for this repository will not be applied.

The Troubleshooting page does not contain anything related to my situation.

The only thing I have trouble with is connecting to tor+https://deb.whonix.org. Every other connection works as expected.

Do you have any other ideas, @Patrick?

See:

Whonix 15 End of Security Support and Deprecation Notice - All users should move to Whonix 16!

Try this Workaround on Gateway first… just to test only, just keep this if Mr. Patrick give you the bless :stuck_out_tongue:

sudo nano /etc/apparmor.d/system_tor

Edit line :
owner /var/lib/tor/ r,
Add ‘w’ after ‘r’:
owner /var/lib/tor/ rw,

reboot GateWay … and try again… good luck

Seems totally unrelated.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]