[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Unable to file a bug report in phrabricator


#1

Hi,
I am trying to file a bug report in phabricator as the wiki told me, but when I go to Maniphest > Create Task and try to create a task I get the following error:

You Shall Not Pass: Maniphest

You do not have permission to prioritize tasks.
Users with the “Can Prioritize Tasks” capability:

  • Administrators can take this action.

#2

Good day,

which priority did you set? As far as I can tell, you may only create tasks with a low or normal priority.

Have a nice day,

Ego


#3

After “Needs Triage” didn’t work, I tried all of them, none of them did work


#4

Confirmed.

A recent phabricator update must have messed with policy so ours no
longer works. Perhaps a bug. Just now updated phabricator. Did not
resolve it.

We want:

  • users being able to create tickets
  • users not being able to modify tickets once created
  • users not being able to modify arbitrary tickets created by others
  • administrators being able to do anything

That should be reasonable.

@fortasse could you look into it please? I’ve used an hour on searching
this issue already to no avail. Probably requires asking their irc
support on how the following policy has to be defined now to archive the
above goals.

Admins link only:
https://phabricator.whonix.org/applications/edit/PhabricatorManiphestApplication/


#5

Sorry, I’m just now getting time to look at this.

If I’m reading this right, we can no longer do this, can we?

https://secure.phabricator.com/book/phabricator/article/forms/#understanding-policies

Their new model is that we can hide the forms, but not actually prevent people from modifying the fields…?

EDIT: Here’s their official post: https://secure.phabricator.com/T10003

These policies are being removed because:

  • all use cases we are aware of are about workflow tailoring, not actual access control, and form customization is a better (more general, more powerful) tool to achieve workflow goals.

Are we an edge case then?


#6

I tried figuring this out multiple times and failed. Can you contact
them please and see what is best we can do here?


#7

I should be able to find time Sunday.


#8

@Patrick: I think I have a solution to this. I’ve configured the default edit policy to follow this:

Can you confirm this is working as you want? @Lobster, can you confirm that you can create tickets again?


#9

There is a problem. Screenshot:


#10

@Patrick: Sorry, can you try again? Apparently I forgot to hit save…


#11

It’s all fine now. Normal user can create and edit its own ticket, but
not edit other users tickets. Good work!


#12

Thanks, I was able to create my ticket.