UFW and VirtualBox


I can access internet from whonix if I have UFW disable but if it is enable, I cannot get internet. I read in internet that if you write


Sorry Continue
in before.rules
it would be possible. But I get an error. ACCEPT is not correct.
Any help to solve the problem_


Where are you installing UFW? in the host?
It should work without any modifications. IIRC it allows outgoing and blocks incoming by default. Won’t interfere with Whonix.
( https://www.whonix.org/wiki/Computer_Security_Education#Host_Firewall )

Don’t install UFW in any Whonix VMs. They have their own firewalls.


Thanks for your reply. I am new to Linux coming from Windows. Well the Ufw is loaded in the host. What I did before enable was to comment the following 5 lines in icmp for better security as I read somewhere maybe should I uncomment them again?. I have the latest Debian and the latest VirtualBox not the 4.3 by debian default but the 5.0


Disabling ICMP Timestamps in your host is recommended.
( https://www.whonix.org/wiki/Computer_Security_Education#Disable_ICMP_Timestamps )
Up to you to figure out how.

Any changes related to ICMP protocol will not affect Whonix connectivity.

Do not change iptables rules unless you know what you are doing. UFW works with Whonix in its default config.


Any way, I tried to install gufw from your page reference and I got an error saying that Virtualbox 4.3 is missing. I understand that ufw has something
to have with virtualbox. I disabled ufw as you say that whonix has its own
firewall and for me is enough and I am going to work only with whonix and not with Debian, the host and so ufw is not an item.
Kind regards


ufw has nothing to do with virtualbox. Your error message is most likely related to the method you used to install version 5. Installing Different Versions of VirtualBox

whonix firewall does not protect host. recommended to have a host firewall as well. ymmv.


Thank you. Thank you very much indeed. I will do that. I did

deb http://httpredir.debian.org/debian/ jessie-backports main contrib non-free to /etc/apt/sources.list,
then apt-get update,
then apt-get install -t jessie-backports virtualbox
I will follow your post in a new installation (the 6th!!). But I own my time. I am retired.
Kind Regards


I installed UFW after VirtualBox latest and I received en ERROR saying that VirtualBox 4.3 was not installed but if I had version 5.0 and could not understand the error message. I will do it again with the 5.0 version and copy the full error. Then I will install ufw before virtualbox ( with the old version) and see.


You should completely remove existing versions of VirtualBox before making a new installation.

Try: sudo apt-get purge virtualbox*


Sounds more like package manager issues rather than something directly related to ufw or virtualbox.