[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Trouble installing updates and updating Tor

I have a brand new whonix install on W10. I keep getting the “Hash Sum mismatch” error. I try the recommended workaround (create a new tor circuit and delete “/var/lib/apt/lists” but it still keeps failing. I ended up creating a script to clear /var/lib/apt/lists, get a new circuit, and retry and after several hours it finally updated. After a few hours an many retries, I was able to get the gateway fully update. I still have monero-gui left to install on the workstation and its been about 8hrs.

Updating Tor hasnt been successful. Using the downloader, after getting the signatures, the download of the browser fails after about 10 seconds with "curl_status_message: [18] - [Partial file. ONly a part of the file was transferred.]). Trying to update in the browser fails while it tries to download.

When I try using Tor, it works ok but frequently crashes.

I’d appreciate any recommendations

Please don’t write Tor when you mean Tor Browser as this is easy to cause confusion.

More on substance of your issue, it looks like this issue where a user contributed a solution:

Yes sorry, I meant tor browser.
I saw that, but the solution did not work.
I have never had Windows VM and hypervisor is not installed
I also have never turned on core isolation

I don’t see a “SMV” mode setting in my bios
VT-x is enabled

This is on my laptop. I just tried whonix on my desktop and I have no issues. I’m not sure what about my laptop is causing issues. Especially since I can run tor browser directly on windows and download tor browser with no issue.

It’s not about Windows VMs. It’s about Windows hosts.

It was reported to be enabled automatically. I.e. user did not enable it manually.

A user reported issues which were gone once switching to Linux.

The post said “uncheck [ ] Virtual Machine Platform
uncheck [ ] Windows Hypervisor Platform”
I have both already unchecked

The post said to disable “core isolation”. I am saying that I have never enabled it AND I checked and it is NOT enabled. It did not automatically get turned on in my case.

Switching to linux is not an acceptable option for me on my laptop.
As I said it DOES work on my desktop windows host.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]