[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Trouble Installing Postgresql

dpkg: dependency problems prevent configuration of exim4-daemon-light:
 exim4-daemon-light depends on exim4-base (>= 4.94.2); however:
  Package exim4-base is not configured yet.

dpkg: error processing package exim4-daemon-light (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of bsd-mailx:
 bsd-mailx depends on default-mta | mail-transport-agent; however:
  Package default-mta is not installed.
  Package exim4-daemon-light which provides default-mta is not configured yet.
  Package mail-transport-agent is not installed.
  Package exim4-daemon-light which provides mail-transport-agent is not configur
ed yet.

dpkg: error processing package bsd-mailx (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 exim4-config
 exim4-base
 exim4-daemon-light
 bsd-mailx
E: Sub-process /usr/bin/dpkg returned an error code (1)

Not sure how to solve this

Thanks in advance

Issue is most likely not caused by Whonix.

If you don’t need that… Purge it…

sudo apt purge bsd-mailx "exim*"

sudo apt install postgresql

Works for me.

sudo apt install --no-install-recommends postgresql

Also works for me.

(–no-install-recommends)

1 Like

Thank you

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]