[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Tor's Browser not installed


#1

When trying to open the Tor Browser in the workstation, I get a few prompts that essentially state the Tor Browser is not installed and asks me which versions (6.3.0, 6.4.0 among two others) I want to install. I have selected both 6.3.0 and 6.4.0 several times now. The download seemingly begins, but after several minutes it eventually gives me this same error:

"ERROR: Failed to download: https://dist.torproject.org/torbrowser/6.0.3/tor-browser-linux32-6.0.3_en-US.tar.xz
Possible reasons:

  • The download server is down.

  • File size exceeded (endless data attack triggered).

  • Tor Browser Downloader (by Whonix developers) has been broken due to upstream changes.
    Recommendations:

  • Try again later. If the error persists it probably won’t solve itself before the next update.

  • Check News: https://www.whonix.org/wiki/Stay_Tuned

  • Manually update: https://www.whonix.org/wiki/Manually_Updating_Tor_Browser
    (Debugging information: curl_status_message: [28] - [Operation timeout. The specified time-out period was reached according to the conditions.])"

Also, on the gateway, I receive the following error: http://i.imgur.com/m0dHk2Z.png

Any help is greatly appreciated. This is v13.0.0.1.1 for both gateway and workstation.

Edit: Also randomly received this error after running apt-get upgrade && apt-get dist-upgrade:

"ERROR: Tor Bootstrap Result:
Tor’s Control Port could not be reached!

Troubleshooting:

  • Confirm that Whonix-Gateway is running.
  • Run whonixcheck on Whonix-Gateway and confirm success.
  • If you’re running multiple Whonix-Workstations simultaneously, confirm that separate IP addresses are configured (see https://www.whonix.org/wiki/Multiple_Whonix-Workstations).
  • Rerun whonixcheck here in this Whonix-Workstation.

(Technical information:)
(Code: 124)
(tor_bootstrap_timeout_type: sigterm)
(tor_bootstrap_status: Variable check_bootstrap_helper_script_output is empty.)
(check_socks_port_open_test: 22)
(Tor Circuit: established)"


#2

The Tor Browser error can be ignored for now since that is likely just a follow up error of the gateway problem. So the gateway error needs to be fixed and then everything else should vanish.

It is a cli only Whonix-Gateway?

Did you uninstall any packages or change any settings?


#3

I lowered the RAM on the gateway so the GUI doesn’t boot. However, I had this same issue before when I was booting into the gateway’s GUI. The problem occurred every time with the GUI as well. This instance was the first time I booted into the CLI. However, I never noticed the gateway’s error before when I booted via GUI because nothing ever showed up via prompt, so booting into CLI this time gave me additional information. So I cannot say whether the gateway was having this error before. The gateway error did not show up immediately, however; I did not notice the gateway error until the Tor Browser failed to download. Thus the gateway error could have occurred before or after the download failure for all I know at this point.

The real issue is that the Tor Browser is not installed on the workstation. I see “Tor is connected” on both the gateway and workstation every time I boot them, but I have no browser to use. The Tor Browser download takes a while (as the prompt says), too, and when it gets to about about 2/3-3/4 downloaded, that is when it errors out. I’m only speculating but it feels like something is throttling the download. Does the workstation v13.0.0.1.1 simply not have the Tor Browser installed? Seems odd (to me) that it isn’t.

I have not uninstalled nor changed anything. I verified both images, ran the whonix check on both, and updated both. The Tor Browser was never installed on the workstation to begin with. Is there a copy of a VBox workstation image with the Tor Browser installed?

Thanks.


#4

Not installed by default, right.

Yes. Reasons and future:
https://www.whonix.org/wiki/Tor_Browser#Not_installed_by_Default

No.


There is a bug that slows downloads down. Try this in Konsole:

update-torbrowser --ordinary

Otherwise install manually as per:


#5

Thanks for the quick response, Patrick. Some very interesting information.

I tried the update-torbrowser command and received the following:

"INFO: Version n/6.0.4 chosen.
INFO: tbb_hardened_version_chosen: false
INFO: Tor Browser language variable TB_LANG was not yet set and no hardened version was chosen. Therefore defaulting TB_LANG to ‘en-US’, ok.
INFO: Because you are not using --nokilltb, now killing eventually still running instances of Tor Browser…
firefox: no process found
INFO: Downloading GPG signature… Will take a moment…
INFO: Downloading:
https://dist.torproject.org/torbrowser/n/6.0.4/sha256sums.txt.asc … Will take a moment…
INFO: CURL_OUT_FILE: /home/user/.cache/tb/files/sha256sums.txt.asc
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (22) The requested URL returned error: 404 Not Found
Failed to download: https://dist.torproject.org/torbrowser/n/6.0.4/sha256sums.txt.asc

Possible reasons:

  • The download server is down.
  • File size exceeded (endless data attack triggered).
  • Tor Browser Downloader (by Whonix developers) has been broken due to upstream changes.

Recommendations:

(Debugging information: curl_status_message: [22] - [HTTP page not retrieved. The requested url was not found or returned another error with the HTTP error code being 400 or above. This return code only appears if -f, --fail is used.])"

Appears the link is broken unless I am mistaken, but then I’m confused as to why the icons on the desktop will offer downloads up to 2/3-3/4 of the way before realizing the link is broken. I will try the download via Iceweasel at this time.

Edit: Tried the update-torbrowser command again and selected a different version of Tor Browser. It is currently downloading at the moment. Going to see if this works. If it doesn’t, then I will try a manual download via Iceweasel. Will respond once everything is good to go or if I hit another brick wall. Thanks again for the information and help, Patrick.


#6

The update-torbrowser command was a success. Thank you very much for the timely responses and help, Patrick!


#7

As a new Whonix user, I’ve been fighting with this for over five days. I’ve re-installed, re-re-installed, changed timeout settings, and spent hours Googling various answers.

THANK YOU THANK YOU THANK YOU! Your answer worked like a charm. Quickly, and without a dumb GUI in the way, obscuring what was going on behind the scenes.

Did I mention? THANK YOU!

  • Russ