[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Torbrowser / Videos not playing

Hi. It seems that torbrowser is having problems playing Videos. Youtube etc. VLC is able to play them but if I open the file in torbrowser it doesn’t play.

It is possible to click through the video but not to play the video.

It affects the virtualbox workstation from non-qubes-whonix.

Please report this to Tor Project as they can fix this. It is likely related to a recent change they made to Tor Browser code.

1 Like

Does the issue also happen on a Debian Linux host with Tor Browser Bundle?

As per https://www.whonix.org/wiki/Free_Support_Principle and https://www.whonix.org/wiki/Tor_Browser#Tor_Browser_Functionality_on_Different_Platforms.

Hi. This is the Browser affected:

8.0.8 (based on Mozilla Firefox 60.6.1esr) (64-bit)

I use an Arch Host with Virtualbox running Whonix-Workstation-XFCE and have not tried TorBrowser outside of vBox.

For testing purposes I installed vlc, some ffmpeg and gstreamer libs etc. Didn’t helped.

There are no errors shown in the browsers console.

Videoplayback fails every test listed here:
https://www.quirksmode.org/html5/tests/video.html

If I click to a specific position two frames are played and it stops again. No matter if embed with html5 or directly opened within the browser.

edit: Upgrading Torbrowser to 8.5a10 (based on Mozilla Firefox 60.6.1esr) (64-bit) doesn’t change anything.

Hi _def

I’m not able to reproduce your issue. (video playback works with no problem) Have you tried adjusting the Tor Browser security slider?

Have you taken HulaHoops advice and reported to TBB bugs?

1 Like

Hi. I didn’t reported it as a bug. Maybe it is just a problem with slow hardware if others can’t reproduce it.

Related?

https://trac.torproject.org/projects/tor/ticket/29904

1 Like

I’ll check that the next time I open the Workmachine.

Edit: Checked. Is a different problem.

This is the one video in a million that works:

<video poster="https://external-preview.redd.it/CJK-kOtolsWXmLfoZ4t89OHsGcmpPggYSuXlvjj_23w.png?width=960&amp;crop=smart&amp;format=pjpg&amp;auto=webp&amp;s=f34cbeffd8d362f98f6582abe54a28dae5de0e1b" loop="" muted="" preload="auto" class="HTML5StreamPlayer__video__regular" autoplay="" src="blob:https://www.reddit.com/bd9aca0d-bf3a-4df0-8706-2557193b64a1">
<source src="https://v.redd.it/ci475whg7jo21/HLSPlaylist.m3u8" type="application/vnd.apple.mpegURL">
</video>

Don’t now why it plays but it does. The console logs some errors.

Specified “type” attribute of “application/vnd.apple.mpegURL” is not supported. Load of media resource https://v.redd.it/ci475whg7jo21/HLSPlaylist.m3u8 failed.
www.reddit.com
All candidate resources failed to load. Media load paused.
index.ts:5:9
Starting Raven release 2a534f749-production public url https://6b5ce051b2ed4032bd906af3de0630cd@oops.redditmedia.com/11
index.tsx:154:9
Cannot play media. No decoders for requested formats: application/vnd.apple.mpegURL
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]