[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor cant connect on Whonix

I am having trouble getting tor to connect in Whonix even if on my pc it connects just fine. I think its because i haven’t set up the internet connection on Whonix and i also have no options to select my router.

Can anyone please let me know what should be selected in the "settings>network>enable network adapter>attached to: " in virtual box for both gateway and workstation?

Should there be "Bridge Adaptor " and have my router selected?

You don’t have to and shouldn’t change these settings. Should work out of the box.

Does the Tor Browser Bundle work on the host?

What version of Whonix are you using? 9.4?

[hr]

Using Windows host?

Could be an issue with VirtualBox. Can you try please if you get a non-Whonix VM to work in VirtualBox? Such as running Debian in a VirtualBox VM?

See this chapter:

That has to be fixed first. Re-install of VirtualBox could work. If you said “no” during VirtualBox network driver install, it won’t work.

I think i acted before letting it fully install.

Can anyone tell me what you have under enable network adapter>attached to: on both the gateway and workstation in the VM Settings>network?

Whonix is 9.4 and yea Tor works on the host

Gateway Adapter 1, attached to, NAT
Gateway Adapter 2, attached to, Internal Network, Whonix

Workstation Adapter 1, attached to, Internal Network, Whonix

No one ever needed to change this. I think you’re on wrong track tampering with these settings.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]