[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor Browser will not maximize?

I could swear I was able to maximize it before, despite the little warning message that pops up along the top, but now, although I have the Workstation resolution set to the native host dimensions (1920x1080) and running in full screen mode under KVM, the Browser refuses to maximize at all.

Other applications such as normal Iceweasel, Dolphin, Konsole etc all maximize properly to the full desktop size, but TBB tries for a split second to take up the entire desktop, and then instantly shrinks back to its original square-shaped window.

Is maximization being prevented deliberately, or has something just gone wrong?

Is there any way to fix this? I was sure it worked previously.

EDIT: I reinstalled using Tor Browser Updater, and it seems to be working correctly again.

EDIT: Problem is back. Every time I close and then re-open Tor Browser again, the maximize button changes from a diamond-shaped icon to a ^ instead, and refuses to maximize the window. It only ever works once, the first time I re/install the browser. Every subsequent time I launch, maximizing fails.

This also happens on plain Debian. This is up to the Tor Browser Bundle which is developed by The Tor Project. Whonix does not interfere with this. This behavior is related to anonymity / browser fingerprinting defense.

https://trac.torproject.org/projects/tor/ticket/7255

[quote=“Patrick, post:2, topic:1376”]This also happens on plain Debian. This is up to the Tor Browser Bundle which is developed by The Tor Project. Whonix does not interfere with this. This behavior is related to anonymity / browser fingerprinting defense.
https://trac.torproject.org/projects/tor/ticket/7255[/quote]

Any idea why it works fine initially, the first time? And also perfectly fine under Fedora, Linux Mint, Windows etc? On these systems I see the toolbar warning, advising not to maximize, but the shrinking isn’t forced on the user.

It seems strange that it only happens some of the time, on some systems haphazardly.

Not using latest version everywhere? Or bug in Tor Browser?

I am using version 5.02 everywhere, but there is definitely something very strange and buggy going on. That ticket/feature description is only intended to warn the user about maximizing, but give him the option to click OK and continue maximized if desired. Not forcibly over-ride the user’s choice no matter what.

But what’s strange is, if I am running the Workstation at an arbitrary resolution like 1366x768, Tor Browser maximizes completely fine, every time, no matter how many times I close and re-open. But if I switch the resolution to 1920x1080, it suddenly changes behavior, and declines to maximize as described above. From that point forward, even if I switch the resolution back again, it still refuses to maximize. I have to re-install again at the lower resolution to get it fixed. I don’t know if just shutting down Workstation and starting it again would be enough to fix it, as I haven’t tried that.

EDIT: Never mind, the problem behavior keeps coming back after a certain amount of time, despite resolution changes.

I have tested further, and found that the refuse-maximize problem does not EVER occur on:

  1. Linux Mint, the host system where I have KVM/Whonix installed. Maximizing is always possible.

  2. Normal Tor Browser 5.02 downloaded from Tor Project’s website and extracted into an arbitrary folder (Downloads etc) within Whonix Workstation. Even here, maximizing is always possible.

It seems only to be the custom modified TBB auto-installed and controlled by Whonix that is affected. From what I can tell, anyway.

Okay, actually, I found out what the issue is, and why its only Whonix’s version that’s affected. It is dependent on what is specified as the Home Page under Firefox/TBB settings. Anything OTHER than “about:tor” will cause this refuse-maximize problem to occur. Whether it is “www.google.com” or the specialized Whonix start page hard-coded into the package, or something else, the problem will occur. If it is “about:tor” there is no problem.

Since it is not so trivial to change this start page on Whonix’s TBB, it is not an easy fix. But at least it is evident what the cause is, and some discussion of this is even referenced in the ticket linked to earlier in this thread.

Can you help fixing this please?

Basically we need to write a bug report that is unspecific to Whonix. I.e. come up with instructions on how to reproduce this issue on plain Debian systems. Post those at The Tor Project’s (TPO) issue tracker.

Basic… Change directory into Tor Browser folder.

Maybe affected (?):

(Changing that file to some other page in the final bug report.)

Not affected (?):

Right?

[hr]

There is a similar issue on Qubes. Any template. Not just Qubes-Whonix. Also in Qubes Debian AppVMs. When you maximize the browser window, it will be maximized, but not actually be used. The new space will be just gray. I didn’t question this until now, thought that’s the way TPO intends this to be since this enforces a common, shared desktop resolution (that can be fingerprinted by remote websites). However, if TPO intends to have an option to ignore this, to be capable to switch to any resolution, then Whonix should not stand in the way.

[quote=“Patrick, post:7, topic:1376”]Can you help fixing this please?

Basically we need to write a bug report that is unspecific to Whonix. I.e. come up with instructions on how to reproduce this issue on plain Debian systems. Post those at The Tor Project’s (TPO) issue tracker.[/quote]

Sure I’ll be glad to help with throwing something together that illustrates the issue for the folks over at the Tor project.

Based on the discussion in that original ticket, it seems that some of the devs are aware of the side-effect behavior caused for anyone who happens to change their home page from “about:tor” to anything else. That isn’t the preferred behavior, but at least one of them seems to be “okay” with it:

> Also, if someone changes their home page to be something other than about:tor, extensions.torbutton.startup_resize_period will remain true. > I am not sure what the impact is.

Depends. If they start maximizing thereafter that won’t work. They get the notification AND their screen is resized. Sounds not so bad to me.

However this was five months ago, and may not represent the majority opinion on the issue. In any event it’s definitely not unique to Whonix, but is the universal behavior for any edition of Tor Browser where the start/home page gets changed.

I will take a look at the existing TPO issue tracker and come up with something concise and duplicable. I don’t currently have a plain Debian installation, but if the steps-to-reproduce work on Linux Mint, based on Ubuntu-via-Debian, I imagine they will be globally applicable.

Yes.

Also note this ‘inability to maximize TBB/automatic override’ display bug is similarly impacting those running:

TBB: 5.5a2 (based on Mozilla Firefox 38.2.1)

CCP

Until this bug gets fixed, users can also try this method (as a non-perfect workaround):

  1. While TBB is in its non-maximized state, grab and drag the lower right corner of TBB to almost the lower right corner of the Workstation 11 viewing area, and release it there.

  2. Now maximize TBB using ^.

  3. Your changes should persist and get you an almost fullscreen view, at least until you end the TBB session.

CCP 8)

Apologies Patrick et al… I became sidetracked with troubleshooting some issues on a completely different Linux (non-whonix) system elsewhere, and still had this maximize bug issue on my todo list.

In the time since, the behavior of Tor Browser seems to have changed, so the Tor project may have already fixed the problem and might not need a new bug report, but I am still noticing some odd inconsistencies. Hopefully this description here below will help to illuminate what’s happening:

Situation 1: New install of TBB 5.03 on host system (Linux Mint)

  • Browser can be successfully maximized at all times, regardless of start page address or configuration. Warning message appears, but maximize occurs as desired.

Situation 2: New manual download/install from website of TBB 5.03 on Whonix Workstation

  • Browser can be successfully maximized at all times, regardless of start page address or configuration (even custom Whonix file:/// is okay). Warning message appears, but maximize occurs as desired.

Situation 3: Auto-update of previously (manually) downloaded/installed older TBB version to 5.03, within Whonix Workstation

  • Browser will NOT maximize with home page set to anything other than “about:tor”. Maximize attempt is refused completely.
  • However, manually entering “about:tor” into the address navigation bar after Browser has opened, will successfully “unlock” the maximize option, and allow maximizing thereafter

Situation 4: Internal pre-installed TBB version that comes with Whonix Workstation, auto-updated to 5.03

  • Browser will NOT maximize with home page set to anything other than “about:tor”. Maximize attempt is refused completely.
  • However, manually entering “about:tor” into the address navigation bar after Browser has opened, will successfully “unlock” the maximize option, and allow maximizing thereafter

Unfortunately I don’t still have an older installed version of TBB on the host Linux Mint system, to test whether the broken behavior still occurs when that version is auto-updated to 5.03. It may again be a non-Whonix related issue, and just simply that all older versions still do this even when updated to 5.03, but brand new fresh installs of 5.03 behave correctly. I am hesitant to submit it as a bug, since new installs work correctly and they would consider it fixed. If old auto-updated versions still act buggy, it would deserve a report, but since I can’t test and verify this myself I don’t have anything to support such a claim.

Does anyone else have an old TBB installed in regular Debian that has auto-updated to 5.03 but not been newly installed? And can report the maximize behavior here?

Patrick, is there any disadvantage to use a newly downloaded/installed instance of TBB within Whonix Workstation, instead of the pre-installed default version? Is there any extra special security configuration in the internal version that is lost when using a web-download install?

I notice that even when running that newly downloaded version, it does not try to launch Vidalia when run, as TBB normally would outside Whonix, and also still defaults to the custom Whonix file:/// as its home page without being set that way. So something in Whonix is still smartly taking over and controlling it to some extent, which might mean it is still just as safe to use as the internally-included TBB? And solves the maximize issue.

Answering the easy points first.

Patrick, is there any disadvantage to use a newly downloaded/installed instance of TBB within Whonix Workstation, instead of the pre-installed default version?
No. Feel free. See also: https://www.whonix.org/wiki/Manually_Updating_Tor_Browser
Is there any extra special security configuration in the internal version that is lost when using a web-download install?
No.
I notice that even when running that newly downloaded version, it does not try to launch Vidalia when run, as TBB normally would outside Whonix, and also still defaults to the custom Whonix file:/// as its home page without being set that way. So something in Whonix is still smartly taking over and controlling it to some extent,
The environment variables.

Some more tech info:

[quote=“Patrick, post:13, topic:1376”]The environment variables.

Some more tech info:

Ah, yes I recognize the TOR_SKIP_LAUNCH=1 variable from elsewhere such as Qubes. I am used to having to set this myself via command line or launch script when using an isolating/transparent proxy, to avoid tor-over-tor. Nice that Whonix sets it globally so that it is applied to all instances automatically.

Perhaps related. If you have a chance, please check this out.

Tor Browser auto resize feature functional in Qubes?
https://www.whonix.org/forum/index.php/topic,1771.0.html

Yes, if freshly downloaded versions are working as opposed to versions updated using the Tor Browser internal updater, then this could be an issue with the Tor Browser internal updater. Not too surprising. Someone from Mozilla said, “the profile folder is bad design, if Firefox keeps crashing or doing otherwise strange things, it’s best to start with a fresh profile folder, that should work because it’s tested a lot”. So in that case, no bug report seems worthwhile. The only advice could be to migrate to a fresh browser profile.

In TBB 5.5a3 on a Debian host, there is an auto resizing feature. But maximizing the browser just works. It may not use a few inches of the screen. But there will be no warning / check box “do you really want to maximize”. There was such a checkbox, right? This check box has been abolished? So this should be expected behavior?

Tested with TBB 5.5a3.

[hr]

Info:

Once environment variable TOR_DEFAULT_HOMEPAGE was set while Tor Browser was started, a Firefox pref will be created. I.e. file

will contain

which means, that unsetting the TOR_DEFAULT_HOMEPAGE variable may not lead to a “clean” testing environment.

[hr]

Optional debugging inspiration…

[hr]

Easy resetting to original state.

Install a fresh version of Tor Browser.

Install git.

Git config (only if you are not already a git user).

Get into Tor Browser folder. Whonix 10.

Whonix 11.

Do experiments.

Reset to original without modifications.

[hr]

Easily starting Tor Browser with “all the” environment variables, specifically the TOR_DEFAULT_HOMEPAGE environment variable unset.

Get into Tor Browser folder.

Tor Browser can no longer be maximized when using a custom browser homepage
https://trac.torproject.org/projects/tor/ticket/17257

https://trac.torproject.org/projects/tor/ticket/17257[/quote]
Was a duplicate. Bug has already been reported.
https://trac.torproject.org/projects/tor/ticket/16725
Attached further information to that bug.

(The bug is triggered in Whonix because Whonix sets the TOR_DEFAULT_HOMEPAGE environment variable.)

Just getting back and seeing all of the updates here now. Bug existed as far back as TBB 4.53 I see. I am still not sure why a fresh install of TBB works correctly, while an auto-updated version does not, both under Whonix. I would think the default home page environmental variable is set universally and would affect all installations, in the same way that the TOR_SKIP_LAUNCH variable does. And indeed on fresh installs the home page still comes up as the custom Whonix local file. But maximizing works properly.

I should point out I am using 5.0.3 since that is the latest version that auto-updates to. 5.5.3a is I think only a beta, and I have not tried any version beyond the current stable. Maybe they have broken the functionality again in 5.53a, but in 5.03 it works correctly even with custom home page set. The warning message does come up, but maximizing is still allowed as requested.

I will try 5.53a and see how it behaves for me, when I am back home and on Whonix again.

EDIT: But it seems they are at least back on the path to fixing it, as indicated by the last comment after yours:

“So it seems the pref is only turned off when about:tor is loaded. We need to find the right place to turn off this pref regardless of whatever page is loaded in a new window. Maybe gk has a suggestion?”

Right now 5.03 just works for me. But if anyone auto-updates and finds it goes back to being broken, the best workaround at present is just to manually quickly go to “about:tor” once at the start of the session, to unlock the maximizing function from then on. Maybe setting it as a one-click bookmark is easiest, to get it out of the way and then proceed to browse normally.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]