[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Tor Browser update error

I am using Qubes. If I run Tor Browser from a disposable qube it starts.
If I run it from a template vm it gives error:

ERROR: User home folder permission issue?

Failed to run the following command:

cp --verbose --recursive --no-clobber /var/cache/tb-binary/.cache /home/user/

Tip: If something does not work, do not arbitrarily try to use sudo / root without indication that this would be appropriate.
That only risks messing up user home folder permissions.

To fix this, you could try:
Start Menu → System → Xfce Terminal

sudo chown --recursive “user”:“user” “/home/user”

Then try starting Tor Browser again.

If I try to run Tor Browser downloader from Whonix template vm it gives this error:

ERROR: GPG download signature could NOT be verified.
Tor Browser update failed! Try again later.
gpg_bash_lib_output_alright_status:
gpg_bash_lib_output_failure:
gpg_bash_lib_output_diagnostic_message:
gpg_bash_lib_internal_gpg_verify_status_fd_file: /var/cache/tb-binary/.cache/tb/gpgtmpdir/gpg_bash_lib_internal_gpg_verify_status_fd_file
gpg_bash_lib_internal_gpg_verify_output_file: /var/cache/tb-binary/.cache/tb/gpgtmpdir/gpg_bash_lib_internal_gpg_verify_output_file
gpg_bash_lib_output_gpg_import_output:
gpg: keybox ‘/var/cache/tb-binary/.cache/tb/gpgtmpdir/pubring.kbx’ created
gpg: /var/cache/tb-binary/.cache/tb/gpgtmpdir/trustdb.gpg: trustdb created
gpg: key 490: public key "Tor Browser Developers (signing key) " imported
gpg: Total number processed: 1
gpg: imported: 1
gpg_bash_lib_output_gpg_verify_output:
gpg: Signature made Fri 07 Jan 2022 11:04:41 AM UTC
gpg: using RSA key 3D16E363
gpg: Can’t check signature: No public key
gpg_bash_lib_output_gpg_verify_status_fd_output:

(keys are changed idk if it is sensible data)

Tor browser only starts from disposable vm qube but it show that an update is available.

Did you read and apply that?

Please see documentation where to run what and what not:
https://www.whonix.org/wiki/Tor_Browser#In_Qubes-Whonix_%E2%84%A2

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]