[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Tor browser refusing to open

Tor browser stopped working after I tried downloading monero. Every time I try running it I receive this error:

ERROR: Failed to start Tor Browser!

Failed to run:

/home/user/.tb/tor-browser/Browser/start-tor-browser --allow-remote 
 "file:///usr/share/homepage/whonix-welcome-page/whonix.html". 

Exited with code: 255 

To see this for yourself, you could try: 
Start Menu -> Applications -> System -> Terminal 
Then run: 
x-www-browser

At first it didn’t give any error messages and just didn’t want to work so I decided to reinstall it using the tor downloader in whonix but now it just gives this error and still doesn’t open. Help pls?

For debugging…

Try start Tor Browser from command line.

https://www.whonix.org/wiki/Tor_Browser#From_the_Command_Line

Or in debug mode.

https://www.whonix.org/wiki/Tor_Browser#In_Debugging_Mode

I tried entering in debug mode and I got this:

XPCOMGlueLoad error for file /home/user/.tb/tor-browser/Browser/libxul.so:
/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.23’ not found (required by /home/user/.tb/tor-browser/Browser/libxul.so)
Couldn’t load XPCOM.

Do these files exist on your disk?

Do these files exist in a VM that is functional?

Exist on my disk:

  • /home/user/.tb/tor-browser/Browser/libxul.so
  • /usr/lib/x86_64-linux-gnu/libstdc++.so.6

dpkg -S /usr/lib/x86_64-linux-gnu/libstdc++.so.6

libstdc++6:amd64: /usr/lib/x86_64-linux-gnu/libstdc++.so.6

i.e. make sure it is installed,

sudo apt install libstdc++6

What does whonixcheck say?

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]